How do I resolve the [WARNING] POM for XXXXX errors when running atlas-create-fecru-plugin?

How do I resolve the [WARNING] POM for XXXXX errors when running atlas-create-fecru-plugin?

Below is the output from when I run the atlas-create-fecru-plugin in my windows cmd window.

Executing: "C:\Atlassian\atlassian-plugin-sdk-3.8\apache-maven\bin\mvn.bat" com.atlassian.maven.plugins:maven-fecru-plugin:3.8:create  -e

+ Error stacktraces are turned on.

[INFO] Scanning for projects...

[INFO] ------------------------------------------------------------------------

[INFO] Building Maven Default Project

[INFO]    task-segment: [com.atlassian.maven.plugins:maven-fecru-plugin:3.8:create] (aggregator-style)

[INFO] ------------------------------------------------------------------------

[WARNING] POM for 'servletapi:servletapi:pom:2.3:runtime' is invalid.



Its dependencies (if any) will NOT be available to the current build.

[WARNING] POM for 'commons-io:commons-io:pom:1.2:runtime' is invalid.



Its dependencies (if any) will NOT be available to the current build.

[WARNING] POM for 'commons-lang:commons-lang:pom:2.1:runtime' is invalid.



Its dependencies (if any) will NOT be available to the current build.

[WARNING] POM for 'javax.mail:mail:pom:1.4.1:runtime' is invalid.



Its dependencies (if any) will NOT be available to the current build.

[WARNING] POM for 'org.codehaus.plexus:plexus-utils:pom:1.0.4:runtime' is invalid.



Its dependencies (if any) will NOT be available to the current build.

[WARNING] POM for 'org.codehaus.plexus:plexus-utils:pom:1.4.2:runtime' is invalid.



Its dependencies (if any) will NOT be available to the current build.

[WARNING] POM for 'org.apache.maven:maven-artifact:pom:2.0.8:runtime' is invalid.



Its dependencies (if any) will NOT be available to the current build.

[WARNING] POM for 'org.apache.maven:maven-project:pom:2.0.8:runtime' is invalid.



Its dependencies (if any) will NOT be available to the current build.

[WARNING] POM for 'org.apache.maven:maven-model:pom:2.0.8:runtime' is invalid.



Its dependencies (if any) will NOT be available to the current build.

[WARNING] POM for 'org.apache.maven:maven-settings:pom:3.0:runtime' is invalid.



Its dependencies (if any) will NOT be available to the current build.

[WARNING] POM for 'org.codehaus.plexus:plexus-utils:pom:2.0.4:runtime' is invalid.



Its dependencies (if any) will NOT be available to the current build.

[WARNING] POM for 'org.codehaus.plexus:plexus-interpolation:pom:1.14:runtime' is invalid.



Its dependencies (if any) will NOT be available to the current build.

[WARNING] POM for 'org.codehaus.plexus:plexus-utils:pom:1.5.5:runtime' is invalid.



Its dependencies (if any) will NOT be available to the current build.

[WARNING] POM for 'org.codehaus.plexus:plexus-component-annotations:pom:1.5.4:runtime' is invalid.



Its dependencies (if any) will NOT be available to the current build.

[WARNING] POM for 'org.codehaus.plexus:plexus-utils:pom:2.0.5:runtime' is invalid.



Its dependencies (if any) will NOT be available to the current build.

[WARNING] POM for 'org.codehaus.plexus:plexus-utils:pom:1.4.1:runtime' is invalid.



Its dependencies (if any) will NOT be available to the current build.

[WARNING] POM for 'org.codehaus.plexus:plexus-utils:pom:1.4.6:runtime' is invalid.



Its dependencies (if any) will NOT be available to the current build.

[WARNING] POM for 'org.apache.maven:maven-plugin-api:pom:2.0:runtime' is invalid.



Its dependencies (if any) will NOT be available to the current build.

[WARNING] POM for 'org.apache.maven:maven-artifact:pom:2.0.2:runtime' is invalid.



Its dependencies (if any) will NOT be available to the current build.

[WARNING] POM for 'org.apache.maven:maven-artifact-manager:pom:2.0.2:runtime' is invalid.



Its dependencies (if any) will NOT be available to the current build.

[WARNING] POM for 'org.apache.maven.wagon:wagon-provider-api:pom:1.0-alpha-6:runtime' is invalid.



Its dependencies (if any) will NOT be available to the current build.

[WARNING] POM for 'org.codehaus.plexus:plexus-utils:pom:1.2:runtime' is invalid.



Its dependencies (if any) will NOT be available to the current build.

[WARNING] POM for 'org.codehaus.plexus:plexus-container-default:pom:1.0-alpha-9:runtime' is invalid.



Its dependencies (if any) will NOT be available to the current build.

[WARNING] POM for 'org.apache.maven:maven-project:pom:2.0.5:runtime' is invalid.



Its dependencies (if any) will NOT be available to the current build.

[WARNING] POM for 'org.apache.maven:maven-model:pom:2.0.5:runtime' is invalid.



Its dependencies (if any) will NOT be available to the current build.

[WARNING] POM for 'org.apache.maven:maven-artifact:pom:2.0.5:runtime' is invalid.



Its dependencies (if any) will NOT be available to the current build.

[WARNING] POM for 'org.apache.maven:maven-project:pom:2.0:runtime' is invalid.



Its dependencies (if any) will NOT be available to the current build.

[WARNING] POM for 'org.codehaus.plexus:plexus-archiver:pom:1.0-alpha-7:runtime' is invalid.



Its dependencies (if any) will NOT be available to the current build.

[WARNING] POM for 'org.apache.maven:maven-project:pom:2.0.4:runtime' is invalid.



Its dependencies (if any) will NOT be available to the current build.

[WARNING] POM for 'commons-logging:commons-logging:pom:1.0.3:runtime' is invalid.



Its dependencies (if any) will NOT be available to the current build.

[WARNING] POM for 'commons-beanutils:commons-beanutils:pom:1.6:runtime' is invalid.



Its dependencies (if any) will NOT be available to the current build.

[WARNING] POM for 'commons-logging:commons-logging:pom:1.0:runtime' is invalid.



Its dependencies (if any) will NOT be available to the current build.

[WARNING] POM for 'commons-collections:commons-collections:pom:2.1:runtime' is invalid.



Its dependencies (if any) will NOT be available to the current build.

[WARNING] POM for 'oro:oro:pom:2.0.8:runtime' is invalid.



Its dependencies (if any) will NOT be available to the current build.

[WARNING] POM for 'xml-apis:xml-apis:pom:2.0.2:runtime' is invalid.



Its dependencies (if any) will NOT be available to the current build.

[WARNING] POM for 'org.apache.maven:maven-plugin-api:pom:2.0.4:runtime' is invalid.



Its dependencies (if any) will NOT be available to the current build.

[WARNING] POM for 'org.apache.maven.reporting:maven-reporting-api:pom:2.0.4:runtime' is invalid.



Its dependencies (if any) will NOT be available to the current build.

[WARNING] POM for 'org.apache.maven.doxia:doxia-site-renderer:pom:1.0-alpha-7:runtime' is invalid.



Its dependencies (if any) will NOT be available to the current build.

[WARNING] POM for 'org.apache.maven.doxia:doxia-core:pom:1.0-alpha-8:runtime' is invalid.



Its dependencies (if any) will NOT be available to the current build.

[WARNING] POM for 'org.codehaus.plexus:plexus-container-default:pom:1.0-alpha-8:runtime' is invalid.



Its dependencies (if any) will NOT be available to the current build.

[WARNING] POM for 'commons-collections:commons-collections:pom:2.0:runtime' is invalid.



Its dependencies (if any) will NOT be available to the current build.

[WARNING] POM for 'org.apache.maven:maven-plugin-api:pom:2.0.6:runtime' is invalid.



Its dependencies (if any) will NOT be available to the current build.

[WARNING] POM for 'org.apache.maven:maven-model:pom:2.0.6:runtime' is invalid.



Its dependencies (if any) will NOT be available to the current build.

[WARNING] POM for 'org.apache.maven:maven-artifact:pom:2.0.6:runtime' is invalid.



Its dependencies (if any) will NOT be available to the current build.

[WARNING] POM for 'org.apache.maven:maven-monitor:pom:2.0.6:runtime' is invalid.



Its dependencies (if any) will NOT be available to the current build.

[WARNING] POM for 'org.apache.maven:maven-settings:pom:2.0.6:runtime' is invalid.



Its dependencies (if any) will NOT be available to the current build.

[WARNING] POM for 'org.codehaus.plexus:plexus-interpolation:pom:1.6:runtime' is invalid.



Its dependencies (if any) will NOT be available to the current build.

[WARNING] POM for 'org.codehaus.plexus:plexus-utils:pom:1.5.1:runtime' is invalid.



Its dependencies (if any) will NOT be available to the current build.

[WARNING] POM for 'org.apache.maven:maven-project:pom:2.0.7:runtime' is invalid.



Its dependencies (if any) will NOT be available to the current build.

[WARNING] POM for 'org.apache.maven:maven-artifact:pom:2.0:runtime' is invalid.



Its dependencies (if any) will NOT be available to the current build.

[WARNING] POM for 'org.apache.maven:maven-model:pom:2.0:runtime' is invalid.



Its dependencies (if any) will NOT be available to the current build.

[WARNING] POM for 'org.codehaus.plexus:plexus-utils:pom:1.4.9:runtime' is invalid.



Its dependencies (if any) will NOT be available to the current build.

[WARNING] POM for 'org.apache.maven:maven-plugin-descriptor:pom:2.0.6:runtime' is invalid.



Its dependencies (if any) will NOT be available to the current build.

[WARNING] POM for 'org.apache.maven:maven-plugin-api:pom:2.2.0:runtime' is invalid.



Its dependencies (if any) will NOT be available to the current build.

[WARNING] POM for 'org.apache.maven:maven-artifact:pom:2.2.0:runtime' is invalid.



Its dependencies (if any) will NOT be available to the current build.

[WARNING] POM for 'commons-io:commons-io:pom:1.4:runtime' is invalid.



Its dependencies (if any) will NOT be available to the current build.

[WARNING] POM for 'commons-collections:commons-collections:pom:3.2.1:runtime' is invalid.



Its dependencies (if any) will NOT be available to the current build.

[WARNING] POM for 'asm:asm-all:pom:20070324:runtime' is invalid.



Its dependencies (if any) will NOT be available to the current build.

[WARNING] POM for 'org.codehaus.plexus:plexus-container-default:pom:1.0-alpha-7:runtime' is invalid.



Its dependencies (if any) will NOT be available to the current build.

[WARNING] POM for 'org.slf4j:slf4j-api:pom:1.6.2:runtime' is invalid.



Its dependencies (if any) will NOT be available to the current build.

[WARNING] POM for 'com.sun.jersey:jersey-server:pom:1.0.3-atlassian-1:runtime' is invalid.



Its dependencies (if any) will NOT be available to the current build.

[WARNING] POM for 'com.sun.jersey:jersey-core:pom:1.0.3-atlassian-1:runtime' is invalid.



Its dependencies (if any) will NOT be available to the current build.

[WARNING] POM for 'org.slf4j:slf4j-api:pom:1.5.6:runtime' is invalid.



Its dependencies (if any) will NOT be available to the current build.

[WARNING] POM for 'com.sun.jersey:jersey-core:pom:1.0.3:runtime' is invalid.



Its dependencies (if any) will NOT be available to the current build.

[WARNING] POM for 'asm:asm:pom:3.1:runtime' is invalid.



Its dependencies (if any) will NOT be available to the current build.

[WARNING] POM for 'org.apache.maven:maven-model:pom:2.2.0:runtime' is invalid.



Its dependencies (if any) will NOT be available to the current build.

[WARNING] POM for 'org.codehaus.plexus:plexus-utils:pom:1.5.15:runtime' is invalid.



Its dependencies (if any) will NOT be available to the current build.

[INFO] [fecru:create]

[INFO] Google Analytics Tracking is enabled to collect AMPS usage statistics.

[INFO] Although no personal information is sent, you may disable tracking by adding <allowGoogleTracking>false</allowGoogleTracking> to the amps plugin configuration in your pom.xml

[INFO] Sending event to Google Analytics: AMPS:fecru - Create Plugin

[INFO] ------------------------------------------------------------------------

[ERROR] BUILD ERROR

[INFO] ------------------------------------------------------------------------

[INFO] Unable to execute mojo



Embedded error: Unable to build project for plugin 'org.apache.maven.plugins:maven-archetype-plugin': Not a v4.0.0 POM. for project org.apache.maven.plugins:maven-archetype-plugin at C:\Atlassian\atlassian-plugin-sdk-3.8\repository\org\apache\maven\plugins\maven-archetype-plugin\2.0-alpha-4\maven-ar

chetype-plugin-2.0-alpha-4.pom

[INFO] ------------------------------------------------------------------------

[INFO] Trace

org.apache.maven.lifecycle.LifecycleExecutionException: Unable to execute mojo

        at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoals(DefaultLifecycleExecutor.java:703)

        at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeStandaloneGoal(DefaultLifecycleExecutor.java:553)

        at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoal(DefaultLifecycleExecutor.java:523)

        at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoalAndHandleFailures(DefaultLifecycleExecutor.java:371)

        at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeTaskSegments(DefaultLifecycleExecutor.java:268)

        at org.apache.maven.lifecycle.DefaultLifecycleExecutor.execute(DefaultLifecycleExecutor.java:181)

        at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:356)

        at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:137)

        at org.apache.maven.cli.MavenCli.main(MavenCli.java:356)

        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)

        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)

        at java.lang.reflect.Method.invoke(Method.java:597)

        at org.codehaus.classworlds.Launcher.launchEnhanced(Launcher.java:315)

        at org.codehaus.classworlds.Launcher.launch(Launcher.java:255)

        at org.codehaus.classworlds.Launcher.mainWithExitCode(Launcher.java:430)

        at org.codehaus.classworlds.Launcher.main(Launcher.java:375)

Caused by: org.apache.maven.plugin.MojoExecutionException: Unable to execute mojo

        at org.twdata.maven.mojoexecutor.MojoExecutor.executeMojoImpl(MojoExecutor.java:122)

        at org.twdata.maven.mojoexecutor.MojoExecutor$ExecutionEnvironmentM2.executeMojo(MojoExecutor.java:403)

        at org.twdata.maven.mojoexecutor.MojoExecutor.executeMojo(MojoExecutor.java:74)

        at com.atlassian.maven.plugins.amps.MavenGoals.createPlugin(MavenGoals.java:158)

        at com.atlassian.maven.plugins.amps.CreateMojo.execute(CreateMojo.java:21)

        at org.apache.maven.plugin.DefaultPluginManager.executeMojo(DefaultPluginManager.java:483)

        at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoals(DefaultLifecycleExecutor.java:678)

        ... 16 more

Caused by: org.apache.maven.plugin.InvalidPluginException: Unable to build project for plugin 'org.apache.maven.plugins:maven-archetype-plugin': Not a v4.0.0 POM. for project org.apache.maven.plugins:maven-archetype-plugin at C:\Atlassian\atlassian-plugin-sdk-3.8\repository\org\apache\maven\plugins\

maven-archetype-plugin\2.0-alpha-4\maven-archetype-plugin-2.0-alpha-4.pom

        at org.apache.maven.plugin.DefaultPluginManager.checkRequiredMavenVersion(DefaultPluginManager.java:286)

        at org.apache.maven.plugin.DefaultPluginManager.verifyVersionedPlugin(DefaultPluginManager.java:198)

        at org.apache.maven.plugin.DefaultPluginManager.verifyPlugin(DefaultPluginManager.java:177)

        at org.twdata.maven.mojoexecutor.MojoExecutor.executeMojoImpl(MojoExecutor.java:113)

        ... 22 more

Caused by: org.apache.maven.project.InvalidProjectModelException: Not a v4.0.0 POM. for project org.apache.maven.plugins:maven-archetype-plugin at C:\Atlassian\atlassian-plugin-sdk-3.8\repository\org\apache\maven\plugins\maven-archetype-plugin\2.0-alpha-4\maven-archetype-plugin-2.0-alpha-4.pom

        at org.apache.maven.project.DefaultMavenProjectBuilder.readModel(DefaultMavenProjectBuilder.java:1609)

        at org.apache.maven.project.DefaultMavenProjectBuilder.readModel(DefaultMavenProjectBuilder.java:1581)

        at org.apache.maven.project.DefaultMavenProjectBuilder.findModelFromRepository(DefaultMavenProjectBuilder.java:562)

        at org.apache.maven.project.DefaultMavenProjectBuilder.buildFromRepository(DefaultMavenProjectBuilder.java:251)

        at org.apache.maven.plugin.DefaultPluginManager.checkRequiredMavenVersion(DefaultPluginManager.java:270)

        ... 25 more

[INFO] ------------------------------------------------------------------------

[INFO] Total time: 13 seconds

[INFO] Finished at: Tue Mar 13 13:03:07 CDT 2012

[INFO] Final Memory: 23M/74M

[INFO] ------------------------------------------------------------------------

110 [AnalyticsThread-1] ERROR com.dmurph.tracking.JGoogleAnalyticsTracker - Error making tracking request

java.net.UnknownHostException: www.google-analytics.com

        at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:195)

        at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:366)

        at java.net.Socket.connect(Socket.java:529)

        at java.net.Socket.connect(Socket.java:478)

        at sun.net.NetworkClient.doConnect(NetworkClient.java:163)

        at sun.net.www.http.HttpClient.openServer(HttpClient.java:394)

        at sun.net.www.http.HttpClient.openServer(HttpClient.java:529)

        at sun.net.www.http.HttpClient.<init>(HttpClient.java:233)

        at sun.net.www.http.HttpClient.New(HttpClient.java:306)

        at sun.net.www.http.HttpClient.New(HttpClient.java:323)

        at sun.net.www.protocol.http.HttpURLConnection.getNewHttpClient(HttpURLConnection.java:970)

        at sun.net.www.protocol.http.HttpURLConnection.plainConnect(HttpURLConnection.java:949)

        at sun.net.www.protocol.http.HttpURLConnection.connect(HttpURLConnection.java:836)

        at com.dmurph.tracking.JGoogleAnalyticsTracker.dispatchRequest(JGoogleAnalyticsTracker.java:463)

        at com.dmurph.tracking.JGoogleAnalyticsTracker.access$100(JGoogleAnalyticsTracker.java:76)

        at com.dmurph.tracking.JGoogleAnalyticsTracker$1.run(JGoogleAnalyticsTracker.java:431)

2 answers

1 accepted

I resolved some of the problems with a correct proxy configuration. I also found out that I had to run with http configured once and then switch the settings.xml to httpS to get the remaining files to download properly.

0 vote

It's not supposed to matter, according to our doc here:

https://developer.atlassian.com/display/DOCS/Maven+Warning+POM+for+X+is+Invalid

However, it's not just the 4.0 warnings. You're also hitting an error later on. Right where you're hitting errors, this is what's supposed to be happening:

[INFO] Setting property: classpath.resource.loader.class => 'org.codehaus.plexus.velocity.ContextClassLoaderResourceLoader'.

[INFO] Setting property: velocimacro.messages.on => 'false'.

[INFO] Setting property: resource.loader => 'classpath'.

[INFO] Setting property: resource.manager.logwhenfound => 'false'.

Do you have any security - either permissions or network access - that might be stopping properties from getting set, perhaps in your home folder?

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Published yesterday in Off-topic

Get to know our Atlassian User Group Leaders from Bengaluru, India

Meet @Dinesh Dhinakaran, @Vishnu Vasudeva, @Rajeev Verma, and Jamshid Nalakath: Our extraordinary AUG leaders from Bengaluru, India. These four work together to strengthen the bonds of their local co...

152 views 0 4
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you