GreenHopper is currently unavailable. This might be because an upgrade task has failed to run or has not not yet completed.

Received error after entering license key. Previously installed GreenHopper and received this error. After being unable to find any information on this error, uninstalled GreenHopper plugin, ran shutdown.sh and then startup.sh. Error message went away. Installed GreehHopper plugin. Entered license key. Error message started showing up again.

5 answers

1 accepted

3 votes

Hello Greg,

Usually this error relates with a lack of permissions of the user on the database, generating a improperly tables structure and leading to errors like the one that you posted. If this is the case, we'll need to get the structure of GH tables rebuilt.

However, the better way to analyze it and ensure that this is indeed the problem, is upon analyzing the errors on your logs, to provide a better assistance. Then, I kindly ask to you fill a request athttps://support.atlassian.com, on the GreenHopper project and provide all the detailed information, such as error messages and log files. :)

Database permissions was the problem. It works now. I found the errors in logs/catalina.out

@ Greg:

We've got the same problem with Greenhopper after an update. Can you please post your solution to this problem and the way how you solved it.

Thanks

Wilhelm

I found errors in logs/catalina.out saying that there were authorization errors when trying to create an index. There were also errors like 'ALTER command denied to user'. Our IT department created the database user id with minimal permissions. The install documentation specifies that you have to grant all access to the jira database. I should have considered that the Jira installation didn't go right for the same reason. It didn't create the indexes either.

What is the process to fix the database permission problem?

Hi Greg,

For this case we recommend you to open a ticket under support.atlassian.com.

One of our Support Engineers will be happy to assist you within this case :)

Cheers,

Fernando | Atlassian

I think this can also be caused by restoring data into a JIRA whose Greenhopper plugin is at an earlier version than that of the source JIRA.

In my case I was getting the error importing JIRA OnDemand data into JIRA 5.2.9. The only clue was this line in the logs, indicating that the OnDemand Greenhopper was at version higher than my local JIRA:

Plugin with key 'com.pyxis.greenhopper.jira' and name 'Atlassian GreenHopper' and version '6.1.4.5' is being updated to version '6.1.3.2'.

Moral of the story: when importing from OnDemand, create a blank JIRA, upgrade plugins, then import your data.

Upgrading the greenhopper addon to a newer version helped me out.

Same problem and same solution. Thanks.

The database permission thingy did the trick for me. Upgraded my 5.2 jira instance with greenhopper 6.0 when this error popped up.

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Published 11 hours ago in Hipchat

Moving from Hipchat to Stride? Here’s what you’ll love

Heya, Hipchat friends! We’re so happy you’re checking out   Stride. Whether you know it or not, you have been instrumental in making Stride come to life. Every feature, design, and functionality...

38 views 0 4
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you