FishEye HTTPS / SSL Web Server --> No HTTP Bind

Is it possible to deactivate the "normal" HTTP WebServer for FishEye? Actually my (HTTPS-) SSL-FishEye-Instance is running on port 8080 and the normal HTTP-Instance is running on port 6060. Because i don't need the "unsave" HTTP-Instance i would like to deactivate it. I have testet it through simply deleting the HTTP-Port in the FishEye-Configuration but after that i got some errors and couldn't log in to the administrator area. Here some snippets from the error-log:

2011-12-21 19:28:11,349 ERROR [btpool0-37 ] org.mortbay.log org.mortbay.log.Slf4jLog-warn - EXCEPTION 
java.lang.IllegalArgumentException: :///admin/admin.do
	at org.mortbay.jetty.HttpURI.parse2(HttpURI.java:166)
	at org.mortbay.jetty.HttpURI.parse(HttpURI.java:109)
	at org.mortbay.jetty.HttpURI.<init>(HttpURI.java:91)

4 answers

1 accepted

This widget could not be displayed.
Daniel Rohan Atlassian Team Dec 20, 2012

Hello osger,

Assuming you have already set up the SSL connector, try removing the XML tag for HTTP bind from your config.xml file directly:


<http bind=":6060"/>

Make sure to stop FishEye/Crucible before editing the config.xml file.

If that still doesn't work for you please open a support ticket at https://support.atlassian.com with the following data:

1. Go to Administration > Global Settings > Server > Debug Logging and Turn Debug Logging "ON".
2. Reproduce the problem.
3. Generate a Support Zip from the Administration menu (Administration >> System Settings >> Atlassian Support Tools >> Support Zip) and attach it to this ticket.

This widget could not be displayed.
Joe Xie Atlassian Team Dec 21, 2011

I believe you have hit this problem : https://jira.atlassian.com/browse/CRUC-4697

This widget could not be displayed.

Was this every resolved? I'm having the same problem trying to disable HTTP.

This widget could not be displayed.

If you remove the entry from your config file by hand you will re-break your configuration every time you edit the server configuration to make a change as FishEye will write out the broken configuration file again.

I "solved" this problem on my end by giving the non-https bind configuration field a localhost value to bind to.

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Posted Wednesday in Teamwork

What teamwork quotes inspire you?

Hey everyone! My name is Natalie and I'm an editor of the Atlassian Blog and I've got a question for you: What's your favorite quote about teamwork?  We've compiled a list here, along with...

195 views 18 7
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you