Failed to start JIRA due to a build number inconsistency

JIRA Access Constraints error. I've been testing the upgrade of our Jira instance from 4.4.4 to 5.2.2 in our dev environment and after rolling back to 4.4.4 from a failed 5.2.2 upgrade attempt, I get the following error.

Failed to start JIRA due to a build number inconsistency. The data present in your database is newer than the version of JIRA you are trying to startup. Database version is: 813 JIRA app version is: 664 Please use the correct version of JIRA. You are running: 4.4.4#664-r167664

I reverted back to a VM snapshot before the up/g of the server and a db back-up before the up/g. Can you advise what could be causing this issue? thanks

3 answers

1 accepted

This widget could not be displayed.
Janet Albion Atlassian Team Jan 08, 2013

Ashmr,

The fail startup because JIRA 4.4.4 tried to connect to database that has been upgraded to 5.2.2. What I am suspecting in this case is that, even though the upgrade failed, the database was partially upgraded to 5.2.2.

Rolling back only can be done like https://confluence.atlassian.com/display/JIRA052/Rolling+Back+a+JIRA+Upgrade

Thanks Janet. The issue is that I restored the db to version prior to the up/g so it contains unchanged tables. I'll run through the oulined process and see if that fixes this - cheers

This widget could not be displayed.

Are you using a fresh DB scheme for the upgrade ?

I used to use fresh DB scheme and install the latest JIRA using this scheme. Once the new JIRA is started, can import the xml from old one.

This widget could not be displayed.

No, haven't tried that, but will give it a go - thanks.

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Posted Wednesday in Teamwork

What teamwork quotes inspire you?

Hey everyone! My name is Natalie and I'm an editor of the Atlassian Blog and I've got a question for you: What's your favorite quote about teamwork?  We've compiled a list here, along with...

147 views 16 7
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you