Failed to register with host Confluence Edited

Hi!

I am working on installing the example add-on : 

https://bitbucket.org/atlassianlabs/atlassian-connect-confluence-example

I followed these instructions:

  • Copy credentials.json.sample to credentials.json and fill in the blanks to enable auto registration of the add-on into your JIRA instance.
  • npm install to install dependencies
  • npm start to run the add-on

I could see the addon (macro) in my Confluence Cloud instance, but I am getting this error message:

D:\devroot\Atlassian-example>npm start

> confluence-connect-example@0.1.0 start D:\devroot\Atlassian-example
> node app.js

Watching atlassian-connect.json for changes
Add-on server running at http://TYCVDINRS7801:3000
Initialized sqlite3 storage adapter
Local tunnel established at https://84bbd884.ngrok.io/
Check http://127.0.0.1:4040 for tunnel status
Registering add-on...
GET /atlassian-connect.json 200 17.365 ms - -
Failed to register with host Confluence:5551410787
Add-on installation timed out
Add-on not registered; no compatible hosts detected
Re-registering due to atlassian-connect.json change
GET /atlassian-connect.json 200 5.954 ms - -
Failed to register with host Confluence:5551410787
Add-on installation timed out
Add-on not registered; no compatible hosts detected

 

Any idea what am I doing wrong? I created the credentials.json file with my info:

{
     "hosts" : {
           "company.atlassian.net": {
                "product": "confluence",
                "username" : "myUser",
                "password" : "*********"
              }
       }
}

Why ACE is not register the addon successfully?

Thank you in advance

3 answers

0 votes
Sam Hall Community Champion Apr 25, 2017

Atlassian Cloud services are having many outages today, particularly related to logins, so this might be the cause.

Check:

https://atlassian.statuspage.io

and the current incident:

https://atlassian.statuspage.io/incidents/kz9n65qlcljd

I'd recommend subscribing to updates about the incident, and waiting until the issues are resolved before then trying again.

Thank you Sam! I will try later!

Hi Sam

I think the login issues were not related to this problem, I have it already.

Hi Brenda, im having the same issue, how were you able to resolve it?

Any updates within this gusy? I'm having same problem here.

Hello there,

I was able to solve this by adding this configuration to credentials.json


{
"hosts" : {
"<domain-name>.atlassian.net/wiki": {
"username" : "admin",
"password" : "**atlassian-password**" }
}
}

Let me know if this is still a problem.

Hope this helps someone!

Thanks,

Lava

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted an hour ago in Featured Groups

Tuesday tips & tricks: What is the Atlassian Community?

It's officially Tuesday, which means it's officially time for another tip to help you better navigate this space we call the Atlassian Community. 😄 I got a great question from community member, Sa...

12 views 0 1
View post

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you