Error installing jira event-listener-plugin: unsatisfied requirements Edited

I am getting errors when trying to install jira event-listener-plugin I wrote. If I try to install it with the .obr file I get the following errors in my jira logfile:

[c.a.u.core.install.ObrPluginInstallHandler] OBR resolver has 2 unsatisfied requirements for installing plugin_1489569791497509241_jiraissuecreatedeventlistenerplugin-1.0.0-SNAPSHOT.obr

2017-07-17 08:40:57,385 UpmAsynchronousTaskManage

r:thread-4 ERROR admin 509x7363x1 1gb99t0 0:0:0:0:0:0:0:1 /rest/plugins/1.0/installed-marketplace [c.a.u.core.install.ObrPluginInstallHandler] Unsatisfied requirement: (&(package=org.apache.log))

2017-07-17 08:40:57,385 UpmAsynchronousTaskManager:thread-4 ERROR admin 509x7363x1 1gb99t0 0:0:0:0:0:0:0:1 /rest/plugins/1.0/installed-marketplace [c.a.u.core.install.ObrPluginInstallHandler] Unsatisfied requirement: (&(package=org.apache.avalon.framework.logger))

 

Does anyone have an idea how I can solve this problem?

1 answer

Hello!

Maybe it's too late, but: do you  require this package in your pom.xml?
Log4j is JIRa default, not avalon. It is not provided by default

Hope, this will help strangers watching this page

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted 8 hours ago in United States

Administrators Cleanup

Good morning, After a long weekend cleaning up, I am still in the cleanup mode 😊. I am curious to know: When do you feel the urgency to cleanup your Atlassian Tools? How many times do y...

15 views 0 0
View post

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you