Error installing SDK on Centos

This question is in reference to Atlassian Developer Documentation: Install the Atlassian SDK on a Linux or Mac system

I am getting the following error when trying to install the sdk on my Centos server. [Errno 14] HTTP Error 404 - Not Found ] 0.0 B/s | 0 B --:--:-- ETA
Trying other mirror.

Error downloading packages:
atlassian-plugin-sdk-5.1.9-1.noarch: [Errno 256] No more mirrors to try.

4 answers

What commands did you execute? 5.1.9 is pretty old - the latest is 6.2.7.

I'm using the commands available in the referenced online documentation. Below is the instruction I'm using...
cd /etc/yum.repos.d/
sudo wget
sudo yum clean all
sudo yum updateinfo metadata
sudo yum install atlassian-plugin-sdk

Please provide me with an updated script for Centos.

I found another developer with the same issue and they were instructed to use the following...

sudo yum install java-sdk

When I ran that script it seems to have installed the sdk package, but I am unable to identify the ATLAS_HOME and none of the atlas commands are working. Can you help me to get this SDK installed and verified?

0 vote

Hi Courtney, 

There's a bug with the Yum installer at the moment (we're tracking it at 

For now, there is a workaround to get the SDK installed:

To install the latest version of the SDK:

I hope this helps!


When trying to run the sudo dnf install ~/Downloads/atlassian-plugin-sdk-6.2.9.noarch.rpm  I'm getting the error that sudo: dnf: command not found.  If I run it without the sudo dnf, I get that the destination folder is missing.  What should I specify for the destination directory?

Hi Courtney,

Which operating system are you using?

Cheers, Mel

Hey Courtney,  Atlassian support were in touch and mentioned you were using Centos.  For Centos, once downloading the file you can run the command:

sudo yum localinstall <path-to-atlassian-sdk.rpm>

Suggest an answer

Log in or Join to answer
Community showcase
Louis De Jaeger
Posted Thursday in Off-topic

Friday fun: your best joke

Hi all Lets make this Friday fun really fun and post one (or more) of your best jokes! The joke can be about an Atlassian product, or just a really fun joke you want to share! I’m not the best j...

174 views 12 3
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot