Epic/theme not showing as column in planning board

I would like the epic/theme field to showing in a column on the planning board. Looking at the config, epic/theme appears to be added by default (can't be removed) at the end:

But when looking at the planning board, it is not there, log hours is at the end instead:

Can someone help?

3 answers

1 accepted

After creating a sprint on the rapid board I went to the list view config again. I had previously removed a number of columns and epc/theme still did not show. Now I added the Sprint field and clicked apply to all issue types. Going to the planning board the Sprint column was added and now the previously unmentioend in config Log work was removed and replaced by Epic/Theme,

0 vote
Renjith Pillai Community Champion Mar 13, 2012

Hope you applied the card style for the List view for the appropriate issue type.

I have clicked applied to all issue types without effect. Note that I did not add epic/theme as a column in the first place, I think the Sprint Theme does that.

Renjith Pillai Community Champion Mar 13, 2012

The scrum theme applies Epic/Theme to the Card View Style, not to the List View style. Could you just select the appropriate issue type in GH administration (Card Styles) and check whether this field is shown for the List View configuration.

Note sure what you mean, this is what I see in config:

Hi boardth,

Make sure you did not hide the field in Field Configuration and it is available for your project (it is added to the screens, issue types).. By default Epic/Theme is set to Global (all issues) and projects but sometimes someone can change this by mistake.

Please remember also that if a field is set as default to a specific issue card view (like Epic/Theme to Epics, Log Work to Technical Task, Story Points to Story) this field cannot be applied to other issue types using Apply to all Issues Types button. In this case when you click Apply to all Issue Types.. Epic/Theme is not editable (you do not see the "X" option to remove it) and it will be not added to other issues.

So.. Tu sum up..

If you want to see a field in all issue types then when accepting setting to all issue types it must be added by you or editable

To fix this you need to:

  1. Select the specific issue where Epic/Theme is not added by default
  2. Add Epic/Theme field do the view (to see X near the name of the field)
  3. Accept this to all issues

This should add Epic/Theme fields to all issues where it is not added by default

I hope that will help you

Any questions.. Feel free to ask



I am not following why you are saying "Select the specific issue where Epic/Theme is not added by default". Epic/Theme is not showing on the planning board (the planning board shows all issues matching what you have filtered). Also, where would I do this fix you suggest? Will it had the Epic/Theme column to the planning board?

Suggest an answer

Log in or Join to answer
Community showcase
Maarten Cautreels
Posted Thursday in Off-topic

Friday Fun: What's your favourite beer/drink

As a Belgian, beer-lover and home brewer, beer is one of my great passions. I love the fact that with just a few ingredients (usually just water, hop and malt) you can create so many different tastes...

285 views 38 9
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot