Emergency Support

We updated some plug ins and now we get this,

2012-11-29 09:48:44,084 http-8443-48 WARN ckoluman 588x7092x4 13i85u1 10.202.36.1 /secure/WorkflowUIDispatcher.jspa googlecode.jsu.util.WorkflowUtils Issue field timeoriginalestimate is not supported.

2012-11-29 09:59:16,217 http-8443-33 ERROR conwukwe 599x8729x1 kcsp82 10.202.36.71 /secure/CommentAssignIssue.jspa atlassian.jira.workflow.DefaultOSWorkflowConfigurator Could not load class 'com.iamhuy.jira.plugin.workflow.AssignFromCustomfieldFunction'

java.lang.ClassNotFoundException: com.iamhuy.jira.plugin.workflow.AssignFromCustomfieldFunction

at org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1680)

at org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1526)

at com.atlassian.core.util.ClassLoaderUtils.loadClass(ClassLoaderUtils.java:88)

at com.atlassian.core.util.ClassLoaderUtils.loadClass(ClassLoaderUtils.java:50)

at com.atlassian.jira.workflow.DefaultOSWorkflowConfigurator$LegacyJiraTypeResolver.loadObject(DefaultOSWorkflowConfigurator.java:162)

at com.opensymphony.workflow.TypeResolver.getFunction(TypeResolver.java:87)

at com.atlassian.jira.workflow.DefaultOSWorkflowConfigurator$JiraTypeResolverDelegator.getFunction(DefaultOSWorkflowConfigurator.java:126)

at sun.reflect.GeneratedMethodAccessor1067.invoke(Unknown Source)

at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)

at java.lang.reflect.Method.invoke(Method.java:597)

at com.atlassian.multitenant.impl.MultiTenantComponentFactoryImpl$AbstractMultiTenantAwareInvocationHandler.invokeInternal(MultiTenantComponentFactoryImpl.java:181)

at com.atlassian.multitenant.impl.MultiTenantComponentFactoryImpl$MultiTenantAwareMethodInterceptor.intercept(MultiTenantComponentFactoryImpl.java:230)

at com.opensymphony.workflow.TypeResolver$$EnhancerByCGLIB$$11b48ba.getFunction(<generated>)

at com.opensymphony.workflow.AbstractWorkflow.executeFunction(AbstractWorkflow.java:860)

at com.opensymphony.workflow.AbstractWorkflow.transitionWorkflow(AbstractWorkflow.java:1265)

at com.opensymphony.workflow.AbstractWorkflow.doAction(AbstractWorkflow.java:567)

at com.atlassian.jira.workflow.OSWorkflowManager.doWorkflowActionInsideTxn(OSWorkflowManager.java:905)

at com.atlassian.jira.workflow.OSWorkflowManager.doWorkflowAction(OSWorkflowManager.java:865)

at com.atlassian.jira.bc.issue.DefaultIssueService.transition(DefaultIssueService.java:449)

at com.atlassian.jira.web.action.issue.CommentAssignIssue.doExecute(CommentAssignIssue.java:196)

at webwork.action.ActionSupport.execute(ActionSupport.java:165)

at com.atlassian.jira.action.JiraActionSupport.execute(JiraActionSupport.java:82)

at webwork.interceptor.DefaultInterceptorChain.proceed(DefaultInterceptorChain.java:39)

at webwork.interceptor.NestedInterceptorChain.proceed(NestedInterceptorChain.java:31)

at webwork.interceptor.ChainedInterceptor.intercept(ChainedInterceptor.java:16)

at webwork.interceptor.DefaultInterceptorChain.proceed(DefaultInterceptorChain.java:35)

...

2012-11-29 09:59:16,220 http-8443-33 ERROR conwukwe 599x8729x1 kcsp82 10.202.36.71 /secure/CommentAssignIssue.jspa atlassian.jira.workflow.OSWorkflowManager Caught exception while attempting to perform action 811 from workflow 68824 on issue 'LB-6930'

com.opensymphony.workflow.WorkflowException: Could not load FunctionProvider class

at com.opensymphony.workflow.AbstractWorkflow.executeFunction(AbstractWorkflow.java:865)

at com.opensymphony.workflow.AbstractWorkflow.transitionWorkflow(AbstractWorkflow.java:1265)

at com.opensymphony.workflow.AbstractWorkflow.doAction(AbstractWorkflow.java:567)

at com.atlassian.jira.workflow.OSWorkflowManager.doWorkflowActionInsideTxn(OSWorkflowManager.java:905)

at com.atlassian.jira.workflow.OSWorkflowManager.doWorkflowAction(OSWorkflowManager.java:865)

at com.atlassian.jira.bc.issue.DefaultIssueService.transition(DefaultIssueService.java:449)

at com.atlassian.jira.web.action.issue.CommentAssignIssue.doExecute(CommentAssignIssue.java:196)

at webwork.action.ActionSupport.execute(ActionSupport.java:165)

at com.atlassian.jira.action.JiraActionSupport.execute(JiraActionSupport.java:82)

at webwork.interceptor.DefaultInterceptorChain.proceed(DefaultInterceptorChain.java:39)

at webwork.interceptor.NestedInterceptorChain.proceed(NestedInterceptorChain.java:31)

at webwork.interceptor.ChainedInterceptor.intercept(ChainedInterceptor.java:16)

at webwork.interceptor.DefaultInterceptorChain.proceed(DefaultInterceptorChain.java:35)

at webwork.dispatcher.GenericDispatcher.executeAction(GenericDispatcher.java:205)

at webwork.dispatcher.GenericDispatcher.executeAction(GenericDispatcher.java:143)

at com.atlassian.jira.web.dispatcher.JiraWebworkActionDispatcher.service(JiraWebworkActionDispatcher.java:151)

at javax.servlet.http.HttpServlet.service(HttpServlet.java:717)

at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:290)

at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)

at com.atlassian.jira.web.filters.steps.ChainedFilterStepRunner.doFilter(ChainedFilterStepRunner.java:78)

at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)

at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)

at com.atlassian.core.filters.HeaderSanitisingFilter.doFilter(HeaderSanitisingFilter.java:44)

at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)

at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)

at com.atlassian.plugin.servlet.filter.IteratingFilterChain.doFilter(IteratingFilterChain.java:46)

at com.atlassian.plugin.servlet.filter.DelegatingPluginFilter$1.doFilter(DelegatingPluginFilter.java:66)

2 answers

Hi Chris,

The problem here appears to relate to the workflow, but it's hard to know what might be causing it based solely on your report that you updated some plugins and now this happens. However, I think the first thing I would suggest that you try is to clear your plugin caches as described in this document: https://confluence.atlassian.com/pages/viewpage.action?pageId=223219163

If this doesn't resolve your issue then I would suggest that you open a ticket with Atlassian Support so that we can investigate deeper into this issue and help you to find a resolution for it.

All the best,
John

What was the resolution of this issue? We're experiencing similar errors. Thanks!

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Tuesday in Featured Groups

Tuesday tips & tricks: What is the Atlassian Community?

It's officially Tuesday, which means it's officially time for another tip to help you better navigate this space we call the Atlassian Community. 😄 I got a great question from community member, Sa...

100 views 3 7
View post

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you