Customfield: Search for "Customfield IS EMPTY" does not return issues

Hello there,

we have created an app for JIRA Server which provides a custom field.

The search for fields with values works fine but the search for empty fields always return zero issues even though there are issues where the custom field is empty.

Do i need to do anything in the searcher to make this work?

Thanks a lot!

Jens

1 answer

I figured out how " IS EMPTY" works for a number custom field.

JIRA translates the JQL to a lucene query with some garbled characters i cant even copy & paste them here:

Unbenannt.png

 But i havent understood how JIRA gets this value into the Lucene Cache.

When i look into the lucene Cache the document does not have a field when the custom field is not set

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Published Monday in Jira Software

How large do you think Jira Software can grow?

Hi Atlassian Community! My name is Shana, and I’m on the Jira Software team. One of the many reasons this Community exists is to connect you to others on similar product journeys or with comparabl...

440 views 6 11
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you