Connector to Eclipse Indigo shows installed but not visible in Add Task Repository

In the Add Task Repository I do not see the JIRA connecter. If I click on Install More Connectors the Atlassian Jira connector shows as already installed. How can I fix this?

This worked for me on a previous version of eclipse.

Sytems info:

Ubuntu 11.04 64bit

Eclipse Indigo Platform version: 3.7.1.r37x_v20110729-9gF7UHOxFtniV7mI3T556iZN9AU8bEZ1lHMcVK

Mylyn: 3.6.0v20110608-1400

Atlassian Connecter: 3.0.2.v20111010 (I have tried other installations as well, from archive and from update site as per instructions)

6 answers

1 accepted

This widget could not be displayed.

It is strange but Myly 3.6.2 solved the problem. In our case it worked fine also with Mylyn 3.6.0

This widget could not be displayed.

Hi,

Can you simply try to remove the Connector and install it once again e.g. via the update site?

http://confluence.atlassian.com/display/IDEPLUGIN/Installing+the+Eclipse+Connector

Cheers,

Jacek

Sigh, that's what I did first. Now I uninstalled and tried from the official connector eclipse update site and I still have the same problem. Also the update site gives the same version number as the donwloaded archinve I installed. 3.0.2.v20111010

Something that may be influencing the situation is that I am running 64bit ubuntu but since I am doing android development I install ia32-libs to bet the android dev wotking correctly.

This widget could not be displayed.

Can you list the installed plugins of Connector? At first sight it looks like the main feature has been installed but JIRA connector plugin is missing. Let's check it.

With Atlassian support I got the following suggestions:

  • make sure your Eclipse is for 64 bits architecture
  • your Java is Sun and not open JDK
  • upgrade your Mylyn to 3.6.2
  • make sure there is nothing suspicious in the log

In my case upgrading to Mylyn 3.6.2 did the trick.

This widget could not be displayed.

I have the same problem (conector installed but not listed when trying to add a task repository) but on Windows.

System info:

Windows 7 Professional 64bit

Eclipse Indigo Platform version: 3.7.2.v201202080800

Mylyn: 3.7.0.v20120319-0200

Atlassian Connector: 3.0.5.v20120518

This widget could not be displayed.

Is there anything suspicious in your Eclipse error log? Some unresolved dependencies? Plugins which did not load?

Cheers,

Jacek

This widget could not be displayed.

It was down to permissions. My user account doesn't have admin priviledges so although I was able to go through the motions of installing the connector and the application registered that I had installed it, something in the process didn't fully complete so it wasn't actually available to me to use.

When I ran Eclipse as an administrator and then reinstalled the connector it installed fully and I am now able to interact with our Jira repository regardless of whether I'm running Eclipse as an administrator or not.

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Published 10 hours ago in Marketplace Apps

The 7 hacks of highly successful automation

...there's anything I've learnt from working, it's that people are lazy! No offense to anyone reading this, but it's true and we can all admit it. The easier you make something for someone, the more...

55 views 0 8
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you