Cant iterate tests in test set


I'm trying to iterate tests in a test set. when I use the following syntax, I get the expected results.:

Tests[0].TestSteps[0].StepNumber: ${Tests[0].TestSteps[0].StepNumber}
Tests[0].TestSteps[0].Step: ${Tests[0].TestSteps[0].Step}
Tests[0].TestSteps[0].Data: ${Tests[0].TestSteps[0].Data}


But when I try to iterate in a loop, I don't get anything. I use the following syntax:

#{for tests}


My question is: Why does it work when I hardcode the array index, but not when I iterate in a for loop?


Thanks for your help.

6 answers

1 accepted

Your template has some typos. I've fixed it. Please try it.


Which versions are you using?


Xporter : 5.0.0

Xray: 2.0.10


They are trial version, but I dougt that it has anything to do.

I've checked in my local Environment and it's working as expected.

Can you share your template?

I stripped most of it and left the part that won't work. The green part works.

Thanks, that's perfect.

Suggest an answer

Log in or Join to answer
Community showcase
Louis De Jaeger
Posted 6 hours ago in Off-topic

Friday fun: your best joke

Hi all Lets make this Friday fun really fun and post one (or more) of your best jokes! The joke can be about an Atlassian product, or just a really fun joke you want to share! I’m not the best j...

23 views 1 2
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot