Cannot upgrade the Universal Plugin Manager

I am having trouble updating the Universal Plugin Manager. When I click the link under the Plugins page to update now. It downloads just fine, then goes to installing and then something goes wrong. I do not get any error messages, nor can I find any in the logs folder. However it just sits with that screen seemingly forever. I have let it go for 30 and 40 minutes with no success.

I also attempted the backup method mentioned in your documentation. I used the old plugins manager. It says it is uploading, then sits at that screen forever. I let it go for 10 minutes before I attempted to quit out.

Each time confluence quits responding, then I have to restart the service. Then when it comes back up, it is the same plugin version 2.0.6.

Any help would be appreciated.

4 answers

Yes, sorry. That is what I meant by the "backup" method. Both have the same result. I am not sure what might be happening. I have confluence setup on it's own server, however it does connect to an SQL server.

Thanks for the suggestion.

Hello James,

Based on your description I would like to suggest you to rebuild your bundled plugins (UPM is bundled also) and after this you can try again to upgrade your UPM, the procedure is the following:

* Stop your Confluence instance;
* Remove/delete the content from the following folders:

a) The <confluence-home>/bundled-plugins folder
b) The <confluence-home>/plugin-cache folder
c) The <confluence-home>/plugins-osgi-cache folder
d) The <confluence-home>/plugins-temp folder

* Start your Confluence and try to upgrade your UPM;

If this approach doesn't work I would suggest you to raise a support ticket and so we can perform a better investigation of this problem that you're experiencing.

I hope this helps.



I have the same problem. Do you know how can I raise a ticket? I'm stuck with this.


log into your account and should be able to raise a support ticket.

Besides cleaning the bundled plujgin's cache, is necessary to try upload such version manually. If it fails it could be some database parameter.

Suggest an answer

Log in or Join to answer
Community showcase
Jason Wong
Published 33m ago in Agility Beta

Welcome to agility

Every team in the world is unique, and so   Atlassian believes   that each and every team's best way of working  needs to  be molded to their unique circumstances  – ...

11 views 1 3
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot