Cannot get Pull Request restrictions to behave as expected. Edited

We turned on BitBucket Branchinng Model and set one required default reviewer (a manager or team lead) as well as one other team membver to approve as well as one successful build. We keep having a problem where after the two approvals it keeps telling us there isn't a successful build, but I can see that the feature branch does in fact have one (sometimes multiple) successful builds. Upon pushing the feature branch Bamboo builds the branch and runs the unit tests. We thought it was something about the branch being disabled after merge because the first time a dev committed/pushed to and recreated a branch to make a change when we first saw it, but now it is set to delete, deleted or inactive plan branches after 21 days.  I can't find anything in the apps that tells me why this is happening.

 

Just found these errors... not sure what they mean though.

Capture.PNG

 

0 answers

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Tuesday in Featured Groups

Tuesday tips & tricks: What is the Atlassian Community?

It's officially Tuesday, which means it's officially time for another tip to help you better navigate this space we call the Atlassian Community. 😄 I got a great question from community member, Sa...

130 views 6 8
View post

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you