Cannot create a Project Link between JIRA and Confluence, although Trusted Applications link exists

When I'm trying to add Project Link in JIRA, I got the following message:

Sorry, there are no links available when using anonymous access, check the permission configuration of the remote application.

Application Link Authentication is: Trusted Applications+OAuth+Basic Access, outgoing and ingoing, synchronized between servers.

JIRA and Confluence servers are not secured.

Atlassian JIRA (v4.4.3#663-r165197)

Atlassian Confluence 4.0.5

6 answers

This widget could not be displayed.
Boris Berenberg Community Champion Aug 22, 2012

You may be hitting:

https://jira.atlassian.com/browse/JRA-27200

Please try creating the link from within Confluence. If this does not work, please comment on the issue above, and mention your instance details.

This widget could not be displayed.

Hi motal,

Sorry for the trouble. ould you mind filing this problem using our support portal?

https://support.atlassian.com/secure/Dashboard.jspa

You'll need to sign up if you haven't used the portal before. Our support team should be able to help you out.

-Simon

Surely that's not the way AAC is supposed to work? At least could we update this when we know the resolution... I experience this on jira startup, however fisheye app links appear to work normally.

This widget could not be displayed.

I have the same issue and I have logged it on Atlassian Support and I am waiting for a response!

This widget could not be displayed.

I have the same issue with JIRA 4.4.4 and Confluence 4.1.3. Trusted applications configured as descriped.

This widget could not be displayed.

Any luck resolving this?

yes, i am hitting that and was looking at that for a while now. I tried steps mentioned in comments but same problem :( not able to use/search confluence pages as well from jira as well.

Boris Berenberg Community Champion Aug 29, 2012

Hey Satishweb,

Take a look at https://jira.atlassian.com/browse/JRA-27200 and see if this is the issue affecting you.

Cheers,
Boris

Boris Berenberg Community Champion Aug 29, 2012

Hey Satish,

Based on the info you provided on the issue, I think you should open a support ticket with us. Proxies tend to introduce a different set of problems and we can research it further. Make sure to mention the above issue so that our support engineers have that extra information when they start working on the issue.

Cheeers,
Boris

it was apache proxy who was creating this trouble. However trouble is only for JIRA to confluence integration. After removing apache proxy, it started working as expected.

This widget could not be displayed.

Try adding your Apache Proxy's IP to trusted IP Patterns under the JIRA/Confluence Application link configuration.

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Posted yesterday in Teamwork

What teamwork quotes inspire you?

Hey everyone! My name is Natalie and I'm an editor of the Atlassian Blog and I've got a question for you: What's your favorite quote about teamwork?  We've compiled a list here, along with...

34 views 3 4
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you