Can't import attachments from 4.2.2 into 5.2

I recently upgraded from 4.2.2 to 5.2 and cannot get the attachments to import into 5.2 correctly.

They're previously under the old 'jiraExtras' folder as:

attachments ADM ADM-110 myattachment.png

but now 5.2 expects them to look like

attachments 10010 myattachment.png

How can I fix this short of updating everything manually?


1 answer

1 accepted

Hi Jeffery,

I'm sorry to say that you're hitting a relatively common problem, but fortunately it is something we have a solution for in this knowledge base article:

However, currently the script will only work for Linux/Unix installs and we don't have a comparable solution for Windows but hopefully you will have access to a Linux/Unix server so that you can use the script to fix your attachments folder.

All the best,

I was able to use cygwin to run the script. Everything works now. Thanks!

Suggest an answer

Log in or Join to answer
Community showcase
Louis De Jaeger
Posted Thursday in Off-topic

Friday fun: your best joke

Hi all Lets make this Friday fun really fun and post one (or more) of your best jokes! The joke can be about an Atlassian product, or just a really fun joke you want to share! I’m not the best j...

178 views 12 3
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot