Can't import attachments from 4.2.2 into 5.2

I recently upgraded from 4.2.2 to 5.2 and cannot get the attachments to import into 5.2 correctly.

They're previously under the old 'jiraExtras' folder as:

attachments ADM ADM-110 myattachment.png

but now 5.2 expects them to look like

attachments 10010 myattachment.png

How can I fix this short of updating everything manually?

Thanks!

1 answer

1 accepted

1 vote
Accepted answer

Hi Jeffery,

I'm sorry to say that you're hitting a relatively common problem, but fortunately it is something we have a solution for in this knowledge base article: https://confluence.atlassian.com/display/JIRAKB/JIRA+Unable+to+Find+Attachments

However, currently the script will only work for Linux/Unix installs and we don't have a comparable solution for Windows but hopefully you will have access to a Linux/Unix server so that you can use the script to fix your attachments folder.

All the best,
John

I was able to use cygwin to run the script. Everything works now. Thanks!

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted 8 hours ago in Featured Groups

Are you managing your users efficiently?

Hi everyone, I am Marek, a Senior Product Manager for Crowd   Server and Data Center   here at Atlassian. I would like to spark a discussion about challenges you have with managing use...

72 views 1 2
View post

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you