Can I build using Java 6 on Bamboo 5.7 or later?

Bamboo 5.7 release notes state:

Bamboo support for Java 6 is deprecated.


Does this mean I can no longer build using Java 1.6 on Bamboo 5.7 or later?

1 answer

1 accepted

0 votes
Accepted answer
Daniel Wester Community Champion Mar 23, 2015

No. It means that the jvm that Bamboo runs in has to be Java7 or higher. You can still build using older java versions - you just have to make sure you set up the JDK capability as per https://confluence.atlassian.com/display/BAMBOO/Defining+a+new+JDK+capability

deprecation means in this context that you should upgrade to a newer java version, but that there is still a way to run it on Java 6.

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Friday in Off-topic

Friday Fun: Dry T-Shirt Competition - What's your BEST (Atlassian) T-Shirt!?

[Note: So it was my turn for Friday Fun and sadly I was sick thanks to rubbish sinus infection... so apologies to most of Europe and Asia for the delayed post. However, I finally got out of bed for t...

141 views 8 3
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you