CSV import rejects configuration file

Hello,

I am trying to import the issues from our old problem tracking system to JIRA using the csv file format. Works fine so far but as I have to import many projects (and also during test) I tried to use the import configuration file. But using the configuration file for the next import even with the same csv file gives an error and stopps processing. JIRA asks for a mapping for the header line and gives the following error message:

Some field mappings are defined in your existing configuration file, however they do not correspond to any of the columns in your CSV file. These mappings will be ignored. Show more

Checking the mapping with "Show more" looks pretty good.

I cannot find a description of a similar problem. Any hints?

BTW: We are using JIRA 6.2.2

Thanks for your help,

Ralph

Config file:

{
"field.IssueKey" : "issuekey",
"field.Components" : "components",
"field.Resolutiondate" : "resolutiondate",
"field.Priority" : "priority",
"value.Status.suspended" : "10012",
"field.Summary" : "summary",
"value.Issue Type.Change Request" : "10400",
"date.import.format" : "dd/MMM/yyyy",
"field.Reporter" : "reporter",
"value.Status.closed" : "6",
"value.Status.open" : "1",
"field.GNATS Audit Trail" : "customfield_11300",
"field.Resolution" : "resolution",
"field.How-to-repeat" : "customfield_10502",
"value.Issue Type.Software Bug" : "1",
"value.Issue Type.Task" : "3",
"value.Status.analyzed" : "10009",
"field.Issue Type" : "issuetype",
"user.email.suffix" : "@xxx.yyyy",
"field.Status" : "status",
"field.Implementation Details" : "customfield_10001",
"field.Assignee" : "assignee",
"field.Description" : "description",
"date.fields" : "Created",
"field.Submitter" : "customfield_11302",
"field.Created" : "created",
"value.Status.implemented" : "10008",
"mapfromcsv" : "true",
"field.External Issue" : "customfield_10400",
"field.Release Notes Comments" : "customfield_10700",
"field.Project.Name" : "project.name",
"field.Project.Key" : "project.key",
"field.Environment" : "environment",
"field.fixversion" : "fixVersions"
}

3 answers

1 accepted

This widget could not be displayed.

Hi All,

The solution was quite easy. My csv file uses the semicolon as separator but the default used by the importer is a comma. I assumed that was stored in the configuration file as well but I was wrong. Using the correct separator the import works as expected.

Cheers,

Ralph

This widget could not be displayed.

Hi Ralph,

This is a really odd behaviour indeed, as this message should only appear if there is a problem with the column mapping in the CSV.

Could you raise a support ticket in support.atlassian.comand attach the log files from <<JIRA_HOME>>/log, the configuration file and the CSV file so we can try to reproduce the same problem locally?

Cheers,

Pietro Schaff

This widget could not be displayed.

Hi Pietro,

I raised a ticket with JSP-199113

I hope you can find the cause.

Cheers,

Ralph

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Posted yesterday in Teamwork

What teamwork quotes inspire you?

Hey everyone! My name is Natalie and I'm an editor of the Atlassian Blog and I've got a question for you: What's your favorite quote about teamwork?  We've compiled a list here, along with...

87 views 13 7
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you