Blog Post macro not displaying posts when new label is created

We are running 4.1. on a corporate server.

When setting a label filter on the Blog Post macro, it will work fine when using a label that was already used on older blog posts.

However when I create a completely label on a blog post, the message: No blog posts found. is displayed when adding the label as filter to the macro.

My conclusion is that the fiter does not pick up "new" labels right away but is there a way to fix that? I've already flushed all the queues and rebuilt the search indexes but it's still not picked up.

Edit: the issues seems to affect anything new in the bolg, including blog posts. New blog posts are also not displayed using the Blog Post Macros. I unfortunately don;t know exactly when this started.

Regards,

Cornelius

1 answer

1 accepted

Hi Cornelius,

A bit of a long shot, but have you tried completely rebuilding the indexes from scratch - http://confluence.atlassian.com/display/DOC/Rebuild+the+Content+Indices+from+scratch ?

If the indexes have somehow become corrupted they may not get rebuilt properly from the UI and may need to be manually deleted and recreated.

Andrew.

I'll try that. Thanks for the advice!

Regards,

Cornelius

Andrew, your suggestion fixed the issue. Many thanks!

Cornelius

Cool, glad it worked. Hopefully you shouldn't have to do that manual rebuild too often. Thanks for marking as correct.

Cheers,

Andrew.

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Posted yesterday in Confluence

Calling all marketing teams who use Confluence - we want to hear from you!

Hi Community! me again 🙂 If you’re a marketing team using Confluence, we want to hear your story! How did you start using Confluence? What are your use cases? What have been some of the benefits?...

72 views 2 3
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you