Bitbucket authentication fails on console

I created a bitbucket account and there created 3 private repositories.

Now I can't clone with the https url. The only way to clone the repositories is via SourceTree (what means at least that my passowrd and username are correct)

When I try to clone on console with:

git clone https://[myUserName][myUserName]/repositoryname.git

I get a prompt: Password for 'https://[myUserName]'

and when I enter my password I get: fatal: Authentication failed

I tried to setup my SSH key but it didn't work.

Could that be somehow related to the fact that I changed my username after creating the repsitories (using the new URLs then of course)?

1 answer

This widget could not be displayed.

I created a new account without renaming the username and everything worked like a charme, so it seems that changing the username is not really supported...

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Posted Wednesday in Teamwork

What teamwork quotes inspire you?

Hey everyone! My name is Natalie and I'm an editor of the Atlassian Blog and I've got a question for you: What's your favorite quote about teamwork?  We've compiled a list here, along with...

147 views 16 7
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you