Bitbucket authentication fails on console

I created a bitbucket account and there created 3 private repositories.

Now I can't clone with the https url. The only way to clone the repositories is via SourceTree (what means at least that my passowrd and username are correct)

When I try to clone on console with:

git clone https://[myUserName]@bitbucket.org/[myUserName]/repositoryname.git

I get a prompt: Password for 'https://[myUserName]@bitbucket.org'

and when I enter my password I get: fatal: Authentication failed

I tried to setup my SSH key but it didn't work.

Could that be somehow related to the fact that I changed my username after creating the repsitories (using the new URLs then of course)?

1 answer

I created a new account without renaming the username and everything worked like a charme, so it seems that changing the username is not really supported...

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Tuesday in Featured Groups

Tuesday tips & tricks: What is the Atlassian Community?

It's officially Tuesday, which means it's officially time for another tip to help you better navigate this space we call the Atlassian Community. 😄 I got a great question from community member, Sa...

130 views 6 8
View post

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you