Bamboo Windows instance doesn't use snapshot EBS

I started a windows instance (Default bamboo windows ami)

Installed a whole bunch of stuff the instance is missing; like updates, .net mvc3, etc

Corrected nant script dlls

Configured scripts

Did a few builds to get source on there

Restarted a few times, built Again

in AWSCreated snapshot

Generated cert and key

Configured bamboo to use the snapshot

Terminated instance

Started new instance

Volume doesn't have any if the stuff I installed and configured. and is not using the specified snapshot EBS

3 answers

1 accepted

The real answer is that this isnt supporting out of the box

i ended up with this


The best way is re-deploy your instance inside one EBS volume and boot up your instance directly form it:

Please if you need any further assistance, raise a support issue on

Lucas Lima

Atlassian Support

0 vote

EBS support for Windows will be available with Bamboo 5.

Suggest an answer

Log in or Join to answer
Community showcase
Maarten Cautreels
Posted Thursday in Off-topic

Friday Fun: What's your favourite beer/drink

As a Belgian, beer-lover and home brewer, beer is one of my great passions. I love the fact that with just a few ingredients (usually just water, hop and malt) you can create so many different tastes...

285 views 38 9
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot