Autocrlf not working on 1.9.4 (Mac OSX Maverics)

having problems commiting files that have been edited by a Windows user. So I opened up the config file in the SourceTree app, and added the line for autocrlf = input, yet it doesn't stop the fatal error message. I also tried the command line $ git config --global core.autocrlf input

which saves to my local user config, but neither keeps the message from appearing. I also tried searching for any other .gitconfig files on my machine, and the only one that I can find is the local one.. so where does the SoureTree .gitconfig file reside? and why does it not solve the fatal message?

1 answer

btw, setting autocrlf = false in the SoureTree config file works; or at least allows me to commit the files without fatal error message, but then our Windows users will have same problem I am guessing..

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted yesterday in Agile

What is Scrum? A good, bad, and ugly answer.

In a world of dark-scrum, faux-scrum, and scrum-butt, the question still remains: What is scrum and how do you do it “right?” That’s the question we set out to answer. I'm Max, I've been teaching c...

73 views 0 3
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you