Ant + Clover using Eclipse Error

<project name="JunitTest" default="test" basedir=".">
	<!-- Setting Varibles -->
	<property name="bindir" location="bin" />
	<property name="srcdir" location="src" />
	<property name="verbose" value="false" />

	<!-- setting paths -->
	<path id="classpath.base" />
	<path id="classpath.test">
		<pathelement location="lib/junit-4.10.jar" />
		<pathelement location="${bindir}" />
		<pathelement location="${srcdir}" />
		<path refid="classpath.base" />
	</path>
	
	<target name="clover.html">
	    <clover-html-report outdir="clover_html" title="Example"/>
	</target>
	
	<!-- deleting up the class files in bin folder -->
	<target name="clean"  depends="clover.html">
		<delete verbose="${full-compile}">
			<fileset dir="${bindir}" includes="**/*.class" />
		</delete>
	</target>

	<!-- conpiling everything in src to bin -->
	<target name="compile" depends="clean">
		<javac srcdir="${srcdir}" destdir="${bindir}" verbose="${verbose}">
			<classpath refid="classpath.test" />
		</javac>
	</target>

	<!-- running te tests -->
	<target name="test" depends="compile">
		<junit>
			<classpath refid="classpath.test" />
			<formatter type="brief" usefile="false" />
			<test name="com.example.TestAll" />
		</junit>
	</target>

</project>

I have the code pasted above in my ant build file. I heep getting the following error. (it seems like I am missing a license)

BUILD FAILED
C:\eclipselocation\Example\build.xml:17: clover.com.atlassian.extras.decoder.api.LicenseDecoderNotFoundException: Could not find any valid decoders in [clover.com.atlassian.extras.decoder.v2.Version2LicenseDecoder@1081d2e, clover.com.atlassian.extras.decoder.v1.Version1LicenseDecoder@1b3f829] for license string <>

I am currently using a trial liscense. According to the documentation, using ant with eclipse shouldn not require an additional license, when I run the tests without the build file Clover works fine.

1 answer

This widget could not be displayed.

Please download the Clover-for-Ant and add

&lt;taskdef resource="cloverlib.xml" classpath="/path/to/your/clover.jar"/&gt;
&lt;clover-env/&gt;

at the beginning of your build.xml file.

Optionally, if your license file is stored in a non-standard location, define the

&lt;property name="clover.license.path" value="/full/path/to/clover.license"/&gt;

property.

See also the:


Regards
Marek

@Marek Parfianowicz I am facing same issue with maven.

Do you have your license key pasted in pom.xml in the <license> option? If yes, then did you keep newline characters? Did you encapsulate the key in a CDATA section?

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Posted 48m ago in Canada

Topic Tuesday - August 21

Hello and happy Topic Tuesday! We would love to continue to find out more about you. Here’s the question: What is one way Atlassian products have shifted the way your team works? Looking forw...

10 views 2 0
View post

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you