All CSS stripped after forwarding

This question is in reference to Atlassian Documentation: Using Apache with mod_proxy

Hi all,

Well I used the article and set the URLs right, then also updated the base URL.

But my whole confluence site is rendered in some basic HTML format! Any ideas how to fix this?Screen Shot 2015-12-12 at 06.36.18.png

1 answer

0 vote

This usually means your proxy is not serving up the css and javascript that Confluence is giving it.  (Did it work ok when you visited the service without going through the proxy?)

It could be a number of things, but the usual culprits are minor errors in the proxypass settings (e.g. "ProxyPass  /conf http://myserver:8090/conf/"  should be "ProxyPass  /conf/ http://myserver:8090/conf/" for some setups) or mostly errors in the Tomcat connector settings - check your server.xml really carefully.

Suggest an answer

Log in or Join to answer
Community showcase
Jason Wong
Published yesterday in Agility Beta

Welcome to agility

Every team in the world is unique, and so   Atlassian believes   that each and every team's best way of working  needs to  be molded to their unique circumstances  – ...

382 views 6 16
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot