After Restart, GreenHopper tries to recreate it's tables and Agile boards no longer work

The initial issue was with the Database Username and Password; the password had expired. I reset the password and restarted the system. When the system came up I saw in the logs several of the Greenhopper related tables where trying to be recreated without success because they already existed. When I tried to access the Rapid Boards, a pink Server Error box was displayed.

I exported the AO_60DB71_* tables as insert statements and then proceeded to DROP the tables. I then ran the Indexer, which recreated these tables; I inserted the data from the export; and finally ran the indexer again. In the past this has solved this sort of issue.

I was then informed

Multiple heads found in rank chain: issueIDs

25816 r0 no prev n25818 ,

28834 r0 no prev n28859 have no parent link. Please update the rank table and ensure that there is exactly one issue that has no child and exactly one that has no parent.

I locked all other users out of the system and repeated the above steps to no avail (figuring someone tried to change something at an inopportune time).

I also started to see things inthe log like the following:

/rest/greenhopper/1.0/xboard/plan/backlog/data.json

/rest/greenhopper/1.0/rapidviews/list.json

We have been experiencing a strange issue with the rapid boards. A card dragged between two columns on a Scrum Work board (wired up properly in the workflow) changes Status but does not appear in the correct column, it instead remains in old column. Sometimes these move later, sometimes they do not move at all.

A final oddity I have seen leading up to this are messages in our log which look like:

2012-12-12 13:26:30,083 http-8080-12 WARN jkimball 806x3596x1 10wujqg 10.41.80.82 /rest/api/1.0/menus/greenhopper_menu service.rapid.view.RapidViewDao could not find entity of type interface com.atlassian.greenhopper.service.rapid.view.RapidViewAO with key 3

These occur even if I uninstall the Greenhopper plugin and re-install it; i.e. there are no boards yet. The system appears to be caching this informating someplace and not refreshing it.

I have marked this as Critical because I have made a workaround using Labels to mark which issues were in active Sprints until I can resolve the problem with the Green Hoper plugin.

1 answer

0 vote
Joe Wai Tye Atlassian Team Dec 12, 2012

Hi Paul,

It seems that you are facing a known issue : https://confluence.atlassian.com/display/GHKB/Multiple+heads+found+in+rank+chain

I would recommend that you raise a support ticket at http://support.atlassian.com. As this relates to your database values, they would need your xml backup to reproduce it and perform tests

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Published 7 hours ago in Hipchat

Moving from Hipchat to Stride? Here’s what you’ll love

Heya, Hipchat friends! We’re so happy you’re checking out   Stride. Whether you know it or not, you have been instrumental in making Stride come to life. Every feature, design, and functionality...

30 views 0 3
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you