A remote agent loading on server ( ip )

With reference to thread http://forums.atlassian.com/thread.jspa?threadID=34704 :

Agent hangs after initial registrations. Available log on bamboo and agent is as follows.

[RemoteAgentManagerImpl] A remote agent is loading on ....

I have tried instructions@http://confluence.atlassian.com/display/BAMKB/Troubleshooting+Remote+Agents

"java NetworkAnalyser BAMBOO_URL"

It passes tests with o problem.

I also tried
"copy the attached log4j.properties file into <bamboo-install>/webapp/WEB-INF/classes"

It did not produce any better log.

My Bamboo version 3.4.3
Just trying to evaluate remote agent on mac, however this is situation so far.....
Alone in dark, any light?

6 answers

1 accepted

It fınally came up to be a port problem at the end. As it was pointed you all. However , ıt ıs quite hard to locate the problem with the logs ın hand.
0 vote

You have to post some logs from the remote agent.

Agent logs are as follows. Serverside logs is as I pasted in original entry.
INFO   | jvm 1    | 2012/04/18 19:53:27 | 2012-04-18 19:53:27,335 INFO [Thread-2] [RemoteAgentHomeLocatorForBootstrap] Agent home located at '/Users/user769/bamboo-agent-home'
INFO   | jvm 1    | 2012/04/18 19:53:27 | 2012-04-18 19:53:27,342 INFO [Thread-2] [RemoteAgent] Starting Bamboo Remote Agent...
INFO   | jvm 1    | 2012/04/18 19:53:27 | 2012-04-18 19:53:27,342 INFO [Thread-2] [RemoteAgent] Starting application context...
INFO   | jvm 1    | 2012/04/18 19:53:28 | 2012-04-18 19:53:28,901 WARN [Thread-2] [PropertyPlaceholderConfigurer] Could not load properties from class path resource [bamboo-init.properties]: class path resource [bamboo-init.properties] cannot be opened because it does not exist
INFO   | jvm 1    | 2012/04/18 19:53:29 | 2012-04-18 19:53:28,924 INFO [Thread-2] [RemoteAgentHomeLocatorForBootstrap] Agent home located at '/Users/user769/bamboo-agent-home'
INFO   | jvm 1    | 2012/04/18 19:53:29 | 2012-04-18 19:53:28,925 INFO [Thread-2] [RemoteAgentHomeDirectoryLayout] Plugin directory: /Users/user769/bamboo-agent-home/plugins
INFO   | jvm 1    | 2012/04/18 19:53:29 | 2012-04-18 19:53:28,925 INFO [Thread-2] [RemoteAgentHomeDirectoryLayout] Plugin cache directory: /Users/user769/bamboo-agent-home/caches/plugins
INFO   | jvm 1    | 2012/04/18 19:53:29 | 2012-04-18 19:53:29,043 INFO [Thread-2] [BambooActiveMQConnectionFactory] Setting broker URL to 'failover:(tcp://bamboo.infonebula.com:54666?wireFormat.maxInactivityDuration=300000)?maxReconnectAttempts=10&initialReconnectDelay=15000'
INFO   | jvm 1    | 2012/04/18 19:53:29 | 2012-04-18 19:53:29,383 INFO [Thread-2] [BambooActiveMQConnectionFactory] Setting broker URL to 'failover:(tcp://bamboo.infonebula.com:54666?wireFormat.maxInactivityDuration=300000)?maxReconnectAttempts=10&initialReconnectDelay=15000'


I finally got some clue. I am serving bamboo over port 80 behind an apache proxy. NetworkAnalyser tool has no problem with BAMBOO_URL on port 80.

However, after some intial messaging with BAMBOO_URL at port 80, bamboo somehow sends agent BAMBOO_URL:8085. And outgoing 8085 is closed.

So to change my question:

I am serving bamboo over port 80 with behind a proxy.(it should be quite common)

How do I make agent to talk over port 80?

0 vote

Please make sure your BaseURL in Bamboo Administration section is set to :80 and not :8085.

Yeah, I am sure your comment will help some guys out there reading this thread.

However , I have already passed that part. My question -as a rephrase- How to make it work over port 80? Suppose I have restrictions serving over 8085 and also have restrictions on agent side as well gor outbound to 8085.

There are only two possible URL sources for the agent - one is the agentServer URL that you've provided on the command line and is now stored in wrapper.conf in your Agent's home directory. The other can come from the BaseURL defined in Bamboo Server.

I am pretty sure the first one is set to :80, because the one from wrapper.conf is used for initial communication which works in your case. My assumption was that the other one is set incorrectly.

But if you're saying that both are set to 80 then you should open a support issue. We'll figure out why it connects to 8085 when you have it configured for 80.

Just making sure: you do realise that you'll have to open a port/lift restrictions for JMS communication, right?

wrapper.conf is a good suggestion. I noticed I did not change it, or it has been overridden during my try-outs. It helped to get rid of the exception connecting to 8085. However situation and logs are still same as I opened the thread. I'll try to update thread with further findings.

I have temoprarily opened 54663-54666 range for JMS. That is another "boss" waiting ahead.


What did you do to fix the problem? I have a very simular setup to you where I run Bamboo behind apache. When I try to connect my remote agents I get the exact same error as you. I have used the NetworkAnalyser tool, reviewed the wrapper settings, general settings, etc, but have not found what is going wrong. Any hints would be great.


- Jeremy Neuharth | Founder


It has been a while, so I shall try to express as I remember.

I changed agent ports/url's in wrapper.conf or the main config file or both to get basic commucation over 80 port.

Also, I added 54663 - 54666 inbound ports open for communication on serverside and outbound on Agent side. This was regarding the JMS. Anyway, one port open should be enough for JMS.

Suggest an answer

Log in or Join to answer
Community showcase
Maarten Cautreels
Posted Thursday in Off-topic

Friday Fun: What's your favourite beer/drink

As a Belgian, beer-lover and home brewer, beer is one of my great passions. I love the fact that with just a few ingredients (usually just water, hop and malt) you can create so many different tastes...

285 views 38 9
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot