00manifest.i corrupt

I'm using TortoiseHg to access Mercurial on BitBucket. I'm new to BitBucket, I just transisioned as part of the Atlassian's move away from SVN.

I have checked in most of my code. While I was doing this I discovered that I forgot to delete the .svn folders.

I used TortoiseHg to remove the files, committed, then deleted the files from the file system. During this process I stated to get the error: RevlogError: integrity check failed on 00manifest.i:28

I ran a verify using the TortoiseHg Workbench. It appears the manifest is OK. Errors don't start showing up until it starts checking files. Then I get 29 files that fail their "integrity check" while "unpacking".

SBN.MegaYellow/Mockups/SearchPage/assets/myBalsamiqProject.pdf@5: unpacking 02068e172171: revlog decompress error: Error -3 while decompressing data: incorrect data check

Some of these files are files that were deleted using the process above. Others are unchaged since the initial commit, and are still in the file system.

I tried to run a recover, but it found no problems.

% hg --repository D:\SBN recover --verbose
no interrupted transaction available
[command returned code 1 Tue Nov 13 11:59:59 2012]

At this point I can no longer interact with the repository.

How do I recover from this?

Thanks in advance,

Michael

1 answer

0 votes

Have you tried following some of the recovery procedures described here: http://mercurial.selenic.com/wiki/RepositoryCorruption ?

I don't see anything on that page about recovering from a "decompress error". Did I miss something?

Suggest an answer

Log in or Sign up to answer
Community showcase
Published yesterday in Statuspage

194 years of downtime: looking back on incident data from 2018

Statuspage customers logged more than 194 years of collective incidents in 2018. That’s a whopping 87% increase from the  104 years logged in 2017 , and we aren’t even through December yet....

58 views 1 5
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you