Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Why doesn't the Editor load? we do not want to deactivate Collaborative editing

We recently started a project of upgrading from Confluence v5.6 to v6.1.
We hit issues in the 6.1 version when trying to publish a new page:
"Unable to communicate with server. Saving is not possible at the moment."
"The editor didn't load this time.
The connection timed out. If it happens again, speak to your Confluence admin. You may be using a proxy server that prevents WebSocket connections."

We are using Firefox and addressing the base URL of the installation, not frontended by any web-server (Apache), no URL redirection.

I turned Collaborative editing into "Limited" and it seems to be working.

But we want to keep Collaborative editing activated.


Can you help ?

2 answers

0 votes
AnnWorley Atlassian Team May 30, 2017


Please review the steps outlined in:

Troubleshooting Collaborative Editing

Also, check whether the following is in the <Confluence_Home>/confluence.cfg.xml file:


    <property name="synchrony.proxy.enabled">true</property>

You may need to open a ticket at so Support can investigate your logs. To include a support zip for the support team, please follow these instructions: Creating a support zip file  It will include configuration files as well as logs to help them take a closer look.


Hi Ann.


Thank you for reacting on this.

We do have the following:

<property name="synchrony.btf">true</property>
<property name="synchrony.encryption.disabled">true</property>
<property name="synchrony.proxy.enabled">true</property>


But to be honest, as we do not use any Apache or other webserver in front at this stage, but just accessing directly via http://<ServerName>:8090,

does this value really need to be set to "true" ?

It is for now, but it did not improve the reported behaviour.


Thank you for any further advice.


[by the way, we already opened this ticket: ]

AnnWorley Atlassian Team May 31, 2017

I am confident your support engineer will get to the bottom of the issue. Please look at this diagram, it shows why I asked to have the synchrony proxy enabled: No reverse proxy 

"If you don't run Confluence behind a reverse proxy, you'll connect to Synchrony via Confluence's internal Synchrony proxy. SSL, if used, is terminated at Tomcat. This is the default configuration, and you shouldn't need to make any additional changes to use collaborative editing."

AnnWorley Atlassian Team May 31, 2017

Just saw on your ticket that the root cause was that Synchrony could not obtain a database connection until you added an argument to the file.

If there is more about the case that you would like to share with the Community, feel free to update the thread in case it can help someone else.

It looks like we solved the issue with

in file


previously we had errors related to Synchrony connection to the DB.

this does not look documented enough in the official guides.



AnnWorley Atlassian Team May 31, 2017

Our replies just crossed. Thank you so much for following up. We will have to work on those guides!

Suggest an answer

Log in or Sign up to answer
Community showcase
Published in Jira

⏰ Day in the life of a Jira Admin!

Hello Community! We thoroughly enjoyed this just-for-fun conversation in the Jira Admin Group about what it's like to be a Jira Admin. For #JiraJuly, our talented designers created these graphics t...

907 views 2 22
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you