Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Some users cannot post comments to specific parts of the page

We have an issue with comments - users from a group, which is allowed to add and delete comments in a workspace cannot always do it. The interesting part is that they can post anywhere on the page except the table with product specifications - the only place where it is actually needed.

 

Where should I dig?

 

Thanks!

 

Max

1 answer

1 accepted

Hi Max.

There are a couple of situations where inline comments don't work. It's not an exact science and includes a lot of guesswork. This is what I can recall out of experience and on short notice:

  • Inside Macros
    Inline Comments don't work in the majority of my user macros (maybe all?). They do sometimes work in macros added with plugins, but not always.
  • Inside Tables (yeah, you figured, huh?)
    Same as with macros. Tables are a bit tricky. Usually if I can't comment in a table, I have marked a word by double-clicking it in a cell that only contains exactly that word. What helps about 30% of the time is to only highlight a portion of the word. But most of the time I have to look for a cell with more text that's adjacent and comment there.
  • In Headlines
    I haven't quite figured out yet, when commenting headlines doesn't work. But it happens.

So if your users can comment textblocks on the very same page but have difficulties only with posting comments in tables, the trick is to get creative. If all else fails, they can still add a page comment and include a row number (if you have automatic numbering turned on) or similar so that the context is clear.

Of course, in your special case, there may be other reasons why commenting doesn't work. But that'd be out of my league. ;-)

 

-- Jens

Oh, there's another situation that I assume to be the reason for inline comments sometimes not working where they should:

If you have solved a previous inline comment, it is not deleted completely. The editor always tries to retain the position of solved comments. Sometimes the highlighting for a new comment starts after the *opening* tag of a former comment and ends after the *closing* tag. If that happens, I assume (guesswork) that creating the comment fails.

If all comments are resolved in a page, you could try to remove all the inline comment tags with the source editor. I can not guarantee that to work and I am not 100% certain that it will be without follow-up issues. The comments will still be available from the Resolved Comments menu but they will have lost context.

Hi Jens!

Thanks for very detailed response, I will definitely look into those options.

Funny thing is that nobody experiences any troubles with comments anywhere in any document except this one group of users. So I am thinking there might be some maybe hidden dependancies on other permissions, which I am not seing

Okay, so what I did was create a new group with absolutely similar permissions and move the users there. This solved my problem

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase

The benefits of using Jira in different departments

Jira is a great tool to use across different departments. Forget that paperwork – switch to Jira and get that tasks done smoothly. Marketing Jira allows for a complete digital transformation of you...

132 views 0 8
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you