It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Edit button missing

I have a Confluence page where the Edit button is missing and I'm unable to edit the page. I've checked the permissions and restrictions and it should be working but it's not. Currently on Confluence version 6.1.0.

4 answers

Same problem in Firefox. I opened the page in Chrome and the buttons went back.

Same issue here. Pages that I've created within my own Confluence space intermittently drop the Edit button. Reappears when I change browsers. 

Brant_Schroeder Community Leader Dec 01, 2017

What version of confluence are you using?  What browser are you using?  Can you consistently get the issue to occur in a specific browser?

Using Cloud version. Consistently occurs in Chrome. Firefox usually corrects it, but only temporarily.

Brant_Schroeder Community Leader Dec 01, 2017

I would submit a support ticket with Atlassian detailing the issue.  Let them know about the issue and what browsers it is occurring in.  They will then be able to test and verify the issue and can fix it.  

Same problem for me - Chrome has the missing buttons but copying and pasting the exact same url into Safari and they appear. 

 

I have tried clearing the cache from Chrome and that didn't work.

0 votes
Brant_Schroeder Community Leader Sep 25, 2017

What restrictions do you have on the page?  Can you provide a screenshot of the permissions.

Here are the restrictions

Permissions.JPGRestrictions.JPGHere is a screenshot of both the permissions and the restrictions.

Brant_Schroeder Community Leader Sep 26, 2017

Jack if you remove the page restrictions and just set the page to no restrictions does that bring the edit button back?

Strangely the edit button has magically reappeared. Thank you for you help.

Brant_Schroeder Community Leader Sep 26, 2017

Good to hear.

Same issue appearing for me as well. I am using Confluence Cloud and edit button along with other options[start/stop watching, share this page with others and ...] on top right of a page were appearing till yesterday. Unable to find it on any of the pages. But edit button is visible in Overview section of the Space but not on any of the pages in that space. I have checked the Permissions and they are fine. I am the creator of the page and edit button should be visible to me atleast. 


I am using Chrome Version 59.0.3071.115 (Official Build) (64-bit)

Changing the browser is not a solution. I will wait for some more time to see if it gets automatically resolved.

I found that when you view the page restrictions and re-add yourself to editing rights and click apply the edit button comes back.
Not sure why the permissions need refreshing...

I have been finding just last week that, after I do an Edit, the bar with the Edit button is not visible, and refresh does not help, but Ctrl+F5 does. BUT I'm only surveying a small sample, i.e. only a few tries, so take my report to mean that indeed the Edit button and the bar it's on are sometimes not visible on some page loads.

I have been having this issue today within spaces that I created and on pages I own.  Once time clearing my cache and closing the tab, then reopening from jira allowed the button to come back.  Using Chrome.

I'm seeing buttons and comments missing until I hard refresh the page. Annoying to have to do this on each page.

https://confluence.status.atlassian.com/ shows there's a partial outage.

Update - The fix from our team was to clear the cache at our end. There maybe corrupt data at the client / browser side cache. Please follow the workaround in this ticket https://jira.atlassian.com/browse/CONFCLOUD-67879 

Like # people like this

Having same issue. That fix worked for me. Thanks!

Thanks, Bruce, it helped me too!

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Opsgenie

Authentication Options for Atlassian’s Opsgenie

What’s New as of May 21, 2020 Hi there! We recently made some changes to the way you can leverage Single-sign on and authorization within Opsgenie. Based on customer preference and feedback we intr...

119 views 1 2
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you