Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Confluence is not working when setting up from using backup data

Edited

Hi All,

I am trying to setup a test server of my original confluence server and i want it exactly the replica of original server. so i am using the backup files and spent many days to set it up but for some reason i am getting 503 error after checking the logs i got an error for few plugins nothing else.

Is anyone else had the same issue or anyone can help. i am going to share the logs.
{code}
[plugin.osgi.factory.OsgiPluginInstalledHelper] availableForTraversal Cannot determine required plugins, cannot resolve bundle 'org.randombits.storage.confluence'

ERROR [ThreadPoolAsyncTaskExecutor::Thread 20] [spring.scanner.extension.ComponentImportBeanFactoryPostProcessor] postProcessBeanFactory Unable to load class 'com.atlassian.bitbucket.auth.RememberMeService' for component importation purposes. Skipping...

[plugin.osgi.factory.OsgiPlugin] enableInternal Detected an error (BundleException) enabling the plugin 'org.randombits.storage.confluence' : Unresolved constraint in bundle org.randombits.storage.confluence [256]: Unable to resolve 256.0: missing requirement [256.0] osgi.wiring.package; (&(osgi.wiring.package=com.atlassian.confluence.content.render.xhtml)(version>=4.0.0)(!(version>=6.0.0)))




{code}

1 answer

0 votes
Brant Schroeder Community Leader Mar 24, 2021

@Asra Iqbal Welcome to community.  It looks like corrupt plugin cache.  I would suggest stopping the Confluence service and deleting the following directories.

  • <confluence.home>/bundled-plugins/
  • <confluence.home>/plugins-cache/
  • <confluence.home>/plugins-osgi-cache/
  • <confluence.home>/plugins-temp/
  • <confluence.home>/bundled-plugins_language/

After deleting the directories start the service and see if Confluence will start.  

@Brant SchroederThanks for the help i tried that already and it was not working. Anyways i appreciate.

Brant Schroeder Community Leader Mar 26, 2021

Did you install the same version of of Confluence as the server where the backup was made?

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Jira Service Management

Security Advisory for Jira Service Management

On October 20, 2021, Atlassian published a security advisory for Jira Service Management. The full advisory is available at this link.  We've seen a number of questions already asking for...

75 views 0 1
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you