Update of Jira Enhancer Plugin broken

All I am getting is:

org.osgi.framework.BundleException: Unresolved constraint in bundle com.tuncaysenturk.jira.plugins.jira-enhancer-plugin [106]: Unable to resolve 106.0: missing requirement [1
06.0] package; (&(package=org.slf4j)(version>=1.6.0))

anyone else expirencing this?

3 answers

1 accepted

Hi,

From Jira 5.1 on when building the plugin OSGI automatically adds org.slf4j 1.6 version to the bundle. Although it works with my local Jira, it does not with several plugin users.

I changed pom.xml and override instructions to force osgi bundle slf4j version 1.5 as below

<Import-Package>org.slf4j;version="1.5",*;resolution:=optional</Import-Package>

Now, it works. I generated new Jira Enhancer Plugin 3.2.0 version and deployed it.

You may download and try it.

Tuncay

Hi Thomas,

From the look of your error, I believe that you need to purge your JIRA plugin caches. This is very easy, all you need to do is:

  1. Shutdown JIRA
  2. Delete the following directory: <JIRA_HOME_DIRECTORY>/plugins/.osgi-plugins/felix
  3. Restart JIRA

This will then clear the caches and repopulate them on startup, after which this error should disappear.

All the best,
John

Sorry, but having to restart Jira for updating a plugin makes no sense to me as the UPM and the Plugin System Two are IMHO there to prevent exacty that...

You don't need to restart JIRA for updating plugins, but occassionally your plugin caches become corrupted and you start getting errors in your logs like the one you have posted above. In these cases it is necessary to purge the plugin caches, which requires a restart but you don't need to purge your plugin caches everytime you update a plugin.

All the best,
John

Hi,

I'm facing the same problem. When I google it, I've run into many issues about OSGI bundling.

Can that be related to Jira 5.1 or something? Because these problems haven't exceeded before Jira 5.1

As I am on 5.0.6 this is not 5.1 related...

Suggest an answer

Log in or Register to answer