Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,463,314
Community Members
 
Community Events
176
Community Groups

Application link between Jira and Confluence on same server

We have an apache proxy with certificates that works. But JIra and Confluence does not trust each other when trying to set up an application link. Traffic seems to go through proxy and terminate. Do I need to set up another set of certificates and point them out in server.xml? Is there a way that application link can be set without ssl?

This is how part that is about certifikate looks like in ssl.conf for apache:

<VirtualHost *:80 *:443>
SSLEngine on
ServerName jira.rmv.se:443
SSLCertificateFile "${SRVROOT}/conf/ssl/star_rmv_se.crt"
SSLCertificateKeyFile "${SRVROOT}/conf/ssl/star_rmv_se.key"
DocumentRoot "${SRVROOT}/htdocs"
CustomLog "${SRVROOT}/logs/ssl_request_jira.log" \
"%t %h %{SSL_PROTOCOL}x %{SSL_CIPHER}x \"%r\" %b"
<Directory "${SRVROOT}/htdocs">
Options Indexes Includes FollowSymLinks
AllowOverride AuthConfig Limit FileInfo
Require all granted
</Directory>

RewriteEngine On
RewriteCond %{HTTPS} off
RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI}

ProxyRequests Off

<Proxy *>
Require all granted
</Proxy>

ProxyPass / http://localhost:8080/
ProxyPassReverse / http://localhost:8080/
</virtualhost>

<VirtualHost *:80 *:443>
SSLEngine on
ServerName confluence.rmv.se:443
SSLCertificateFile "${SRVROOT}/conf/ssl/star_rmv_se.crt"
SSLCertificateKeyFile "${SRVROOT}/conf/ssl/star_rmv_se.key"
DocumentRoot "${SRVROOT}/htdocs"
CustomLog "${SRVROOT}/logs/ssl_request_confluence.log" \
"%t %h %{SSL_PROTOCOL}x %{SSL_CIPHER}x \"%r\" %b"
<Directory "${SRVROOT}/htdocs">
Options Indexes Includes FollowSymLinks
AllowOverride AuthConfig Limit FileInfo
Require all granted
</Directory>

RewriteEngine On
RewriteCond %{HTTPS} off
RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI}

ProxyRequests Off

<Proxy *>
Require all granted
</Proxy>

ProxyPass /synchrony http://<internal_domain>:8091/synchrony
<Location /synchrony>
Require all granted
RewriteEngine on
RewriteCond %{HTTP:UPGRADE} ^WebSocket$ [NC]
RewriteCond %{HTTP:CONNECTION} Upgrade$ [NC]
RewriteRule .* ws://<internal_domain>:8091%{REQUEST_URI} [P]
</Location>

ProxyPass / http://localhost:8090/
ProxyPassReverse / http://localhost:8090/
<Location />
Require all granted
</Location>
</virtualhost>

# End SNI Demonstration Config

 

Thankful for suggestions.

All best!

Maria

0 answers

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events