It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

email settings TLS

Since Microsoft turns off TLS 1.0 and TLS 1.1, I need to change these settings in Jira's Desktop. Where do I do it?

POP3 and Imap will be turn off if you are using O365.

 

Best Regards

1 answer

0 votes
Daniel Eads Atlassian Team Feb 27, 2020

Hey Mikael,

Thanks for reaching out ahead of time to prepare for Microsoft's deprecation of TLS 1.0 and 1.1 for email connections to Office 365. After June 2020 when TLS 1.0 and 1.1 will be rejected on Microsoft's side, POP3 and IMAP will continue working if they're handled over TLS 1.2.

In Jira Server, some extra configuration is needed to enable TLS 1.2 for incoming and outgoing mail. In order to apply these settings, you'll need to be running Jira on Java 8 or above. If you're not sure about this, you can use Jira's System Information Page to determine which version of Java you're running under. Again, you want Java 8 or above in order to apply these settings. Most installations of Jira should be fine, although you may find Java 7 in very old versions of Jira or servers that were set up a long time ago.

  1. Get ready to add startup parameters to Jira - instructions for Linux and Windows here
  2. Add these two startup flags:
    -Dmail.imaps.ssl.protocols="TLSv1.2"
    -Dmail.smtp.ssl.protocols="TLSv1.2"
  3. Restart Jira

After this, Jira should negotiate a TLS 1.2 connection with Office 365!

Cheers,
Daniel

 

Atlassian documentation reference: JIRA Mail initiates TLSv1 connection only 

Hi Daniel Eads, 

We are using Jira service desk = no server where I can do any changes! Sorry about not writing that in to the question. All that we have is a web login. 

I can see that the mail addresses that we are using accessing 0365 using TLS 1.0. 

So do you have a soultion for me, when you have this new parameters?

Hi Mikael, 

Not sure if this helps. Here's what I've done to get email working between Office 365 and Jira Service Desk Cloud edition, and hopefully, I'm not anticipating and issues when MS deprecate the support for TLS 1.0. 

 

  • Ensure the mailbox on O365 has the IMAP protocol enabled against it. ( I actually had this turned of for every account in our tenant, and this initially caught me out ) 
  • In Jira, click on the Cog  -> Jira Settings -> System -> Mail -> Incoming Mail Server 
  • Click edit. Then ensure you have Protocol set to SECURE_IMAP. Hostname is outlook.office365.com and you have your correct username and password for the account set. 

I think the selection for SECURE_IMAP automatically ensures port 993 is set. 

And that should be it. 

regards

Dieter

Like Mikael_Opdal likes this

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Next-gen

Keyboard shortcuts have arrived for next-gen projects!

...ollected feedback from users around the lack of shortcuts, and we’re here to address that: In next-gen projects, I miss the keyboard shortcuts badly. This is particularly true on the Board, but also i...

283 views 2 5
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you