Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

US DOD -- How do you setup confluence with security blocking browsers

 

I am working on a Department of Defense network and system.

Even with HIPS temporarily disabled I cannot use a browser on the server. I get an IE enhanced security error. When I attempt to  access confluence (installed but not setup) from my laptop using the URL  http://servername:8090 I get an error that the server refused the connection. Any suggestions?

 

2 answers

0 votes

A refused connection often means the system isn't running on that url.

I would be very surprised to find a system running for a defence department over http - that's a plain text connection!  I would very much expect it to be https, and probably with the port removed as well.

Are you sure you have the right url there?

I tried https as well. the Atlassian documentation has the url http://localhost:8090

Ok, but where is your system actually running?  If you have not changed the defaults, then it should be on the url in the docs, but a refusal suggests a network block (which could be a firewall on your machine or even a browser setting), or that there is a service listening on that port but not serving anything.

I'd like to see the full error message, but the next thing to check is if Confluence is actually running and listening on that port. 

I don't know how to check process ports on Windows, but "netstat" is used on Unix-like systems and you can search the output for 8090.  May be easier to look for the process - in the process management, you'll see Confluence, Tomcat, Java (one or all!).

If it does appear to be running, then check the end of the application log <confluence home>/logs/atlassian-confluence.log , If that does not appear, or looks like Confluence has failed or is not currently running, the next place to look is the Tomcat log - <confluence install>/logs/catalina.out

Hi,

 

can you check on the server side if the application is running on the specified port? Moreover, do you have such port opened on the firewall?

 

Last but not least, are you able to connect to this port using for example telnet?

network team says the port is open. I have installed Confluence according to instructions using the port 8090. Using telnet or SSH2 I also get the connection refused error

Are you able to verify using netstat or similar tool that the application is running on the specified port on the server?

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Marketplace Apps & Integrations

☕️ Monday coffee with Jexo: Weekly Atlassian news roundup | 21st June 2021

Hi community 👋, as every Monday we're bringing you a quick update on what happened in the Atlassian ecosystem last week. There were a few interesting events like for example the announcement of th...

51 views 0 6
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you