xcodebuild not found

When using the XCode plugin I keep getting xcodebuild not found.

I have tried multiple xcodebuild locations and i can run the command successfully from terminal and from the Bambo directory via terminal.

I have also added the path to my xcodebuild to the Babmboo.sh script.

Any suggestions why Bamboo cannot see my xcodebuild executable?

1 answer

This widget could not be displayed.

Hi Lee,

I know you probably have figured this out but I just thought I'd post an answer here in case anyone else comes looking for it.

Rather than type the xcodebuild path as instructed next to that textfield, enter 'iphoneos' for both label and path, and Bamboo should be able to pick up xcodebuild and run it using the latest iphoneos SDK.

Cheers,

Rog

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Aug 22, 2018 in Marketplace Apps

How a Marketplace app tech team is achieving gender diversity

Hello! My name is Genevieve Blanch, and I'm the Marketing Manager at RefinedWiki, creators of apps to give teams the tools to customize Atlassian platforms. Currently, 44% of the tech team at Re...

486 views 3 18
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you