xcodebuild not found

When using the XCode plugin I keep getting xcodebuild not found.

I have tried multiple xcodebuild locations and i can run the command successfully from terminal and from the Bambo directory via terminal.

I have also added the path to my xcodebuild to the Babmboo.sh script.

Any suggestions why Bamboo cannot see my xcodebuild executable?

1 answer

Hi Lee,

I know you probably have figured this out but I just thought I'd post an answer here in case anyone else comes looking for it.

Rather than type the xcodebuild path as instructed next to that textfield, enter 'iphoneos' for both label and path, and Bamboo should be able to pick up xcodebuild and run it using the latest iphoneos SDK.

Cheers,

Rog

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Published Jul 10, 2018 in Marketplace Apps

If you’re an Atlassian app developer, you’ll want to know about Atlas Camp!

This September 6-7, hundreds of Atlassian App developers will flock to Barcelona Spain to build skills, discover product roadmaps, meet face-to-face with the Atlassian team, and learn how to extend t...

136 views 0 4
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you