${url} is not a valid reference

Hello

Why I do I keep getting this error and how do I avoid it. Can you please let me know

13:23:44.648,assignee=com.atlassian.crowd.embedded.ofbiz.OfBizUser@cf66d74f,reporter=com.atlassian.crowd.embedded.ofbiz.OfBizUser@ab3a6692],remoteUser=com.atlassian.crowd.embedded.ofbiz.OfBizUser@ab3a6692,notificationType=Current_Reporter,eventTypeId=1,templateId=1] WARN ServiceRunner Mail Queue Service [velocity] org.apache.velocity.runtime.exception.ReferenceException: reference : template = templates/email/html/includes/fields/priority.vm [line 1,column 1] : ${url} is not a valid reference.
at org.apache.velocity.runtime.parser.node.ASTReference.render(ASTReference.java:277)
at org.apache.velocity.runtime.parser.node.SimpleNode.render(SimpleNode.java:230)
at org.apache.velocity.runtime.parser.node.ASTStringLiteral.value(ASTStringLiteral.java:138)
at org.apache.velocity.runtime.parser.node.ASTExpression.value(ASTExpression.java:51)
at org.apache.velocity.runtime.parser.node.ASTSetDirective.render(ASTSetDirective.java:95)
at org.apache.velocity.runtime.parser.node.ASTBlock.render(ASTBlock.java:55)
at org.apache.velocity.runtime.parser.node.SimpleNode.render(SimpleNode.java:230)
at org.apache.velocity.runtime.parser.node.ASTIfStatement.render(ASTIfStatement.java:89)
at org.apache.velocity.runtime.parser.node.SimpleNode.render(SimpleNode.java:230)
at org.apache.velocity.runtime.directive.VelocimacroProxy.render(VelocimacroProxy.java:171)
at org.apache.velocity.runtime.parser.node.ASTDirective.render(ASTDirective.java:114)
at org.apache.velocity.runtime.parser.node.SimpleNode.render(SimpleNode.java:230)
at org.apache.velocity.runtime.directive.Parse.render(Parse.java:181)
at org.apache.velocity.runtime.parser.node.ASTDirective.render(ASTDirective.java:114)
at org.apache.velocity.runtime.parser.node.SimpleNode.render(SimpleNode.java:230)
at org.apache.velocity.app.VelocityEngine.evaluate(VelocityEngine.java:300)
at org.apache.velocity.app.VelocityEngine.evaluate(VelocityEngine.java:202)
at com.atlassian.velocity.DefaultVelocityManager.getEncodedBodyForContent(DefaultVelocityManager.java:143)
at com.atlassian.jira.mail.MailingListCompiler$1.processRecipient(MailingListCompiler.java:296)
at com.atlassian.jira.mail.NotificationRecipientProcessor.process(NotificationRecipientProcessor.java:39)
at com.atlassian.jira.mail.MailingListCompiler.addMailsToQueue(MailingListCompiler.java:318)
at com.atlassian.jira.mail.MailingListCompiler.access$400(MailingListCompiler.java:42)
at com.atlassian.jira.mail.MailingListCompiler$NotificationCompiler.addEmailsToQueue(MailingListCompiler.java:463)
at com.atlassian.jira.mail.MailingListCompiler$NotificationCompiler.sendLists(MailingListCompiler.java:433)
at com.atlassian.jira.mail.MailingListCompiler$NotificationCompiler.sendNoLevelsIgnoreGroup(MailingListCompiler.java:413)
at com.atlassian.jira.mail.MailingListCompiler$NotificationCompiler.sendToAll(MailingListCompiler.java:408)
at com.atlassian.jira.mail.MailingListCompiler.sendLists(MailingListCompiler.java:140)
at com.atlassian.jira.mail.IssueMailQueueItem.send(IssueMailQueueItem.java:154)
at com.atlassian.mail.queue.MailQueueImpl.sendBuffer(MailQueueImpl.java:66)
at com.atlassian.jira.service.services.mail.MailQueueService.run(MailQueueService.java:28)
at com.atlassian.jira.service.JiraServiceContainerImpl.run(JiraServiceContainerImpl.java:61)
at com.atlassian.jira.service.ServiceRunner.execute(ServiceRunner.java:47)
at org.quartz.core.JobRunShell.run(JobRunShell.java:195)
at com.atlassian.multitenant.quartz.MultiTenantThreadPool$MultiTenantRunnable.run(MultiTenantThreadPool.java:72)
at org.quartz.simpl.SimpleThreadPool$WorkerThread.run(SimpleThreadPool.java:520)

Thanks

Abe

4 answers

This widget could not be displayed.

I think you have a customized atlassian-jira/WEB-INF/classes/templates/email/html/includes/fields/priority.vm , compare it with the default, whats different?

It looks as if it contains a $url reference somewhere that isn't valid. Removing the $url reference will fix the problem, perhaps it was meant to be (${priority.iconUrlHtml} ? (JIRA5.2), need the content of that template to be specific...

can you paste the content of your priority.vm file? , 5.0.2 still has no $url reference, indiciating a customization...

Hi

This is from fresh install of JIRA 5.0.2

Thanks

Abe

This widget could not be displayed.

$url comes from renderIcon macro. Does your priority have an icon url?

This widget could not be displayed.
Joe Wai Tye Atlassian Team Nov 18, 2012

Hi Abe,

If there have been no changes done to the vm file, may I know if you have any third-party plugins? Could you try enabling plugin Safe Mode and see if the problem persists? You can find more info on safe mode here : https://confluence.atlassian.com/display/AOD/Disabling+or+Enabling+a+JIRA+Plugin#DisablingorEnablingaJIRAPlugin-Disablingandenablingalluser-installedplugins%28SafeMode%29

Cheers,

Joe

This widget could not be displayed.

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Aug 22, 2018 in Marketplace Apps

How a Marketplace app tech team is achieving gender diversity

Hello! My name is Genevieve Blanch, and I'm the Marketing Manager at RefinedWiki, creators of apps to give teams the tools to customize Atlassian platforms. Currently, 44% of the tech team at Re...

487 views 3 18
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you