"Display options" not available when Search yields 0 or 1 result.

The consolidation of both macros into one in version 5 of is great. However, "Display options" is greyed out if the Search yields either no results, or just one. This means I cannot set the display to "Total issue count" (as I require) in such scenarios, when defining the macro. (I'm using Confluence 5.1.4 and JIRA 6.0.3, with an Application Link that enables JIRA to trust Confluence. )

5 answers

1 accepted

Having raised this as a support call, Atlassian have confirmed it is a bug in version 5.0 - they will progress it under https://ecosystem.atlassian.net/browse/CONFJIRA-259. I have reverted to version 4.0.29 in the meantime.

Paul,

Have you tried adding the jira dashboard gadgets to your confluence pages as explained here : https://confluence.atlassian.com/display/DOC/Adding+JIRA+Gadgets+to+a+Confluence+Page

These might help you out.

Best regards,

Peter

Hi Peter, thank you for your response.

I'm afraid I don't see the link between what I'm trying to do and the use of a gadget. I'm just trying to reproduce what I already do with the version 4.0.29 of this macro, which is to show the result of a JIRA query in a Confluence page in "Total issue count" form, rather than the list of matching issues. I've not had to make use of a gadget before.

However, when I define the macro and the JIRA Search yields 0 or 1 result, I cannot select "Display as: Total issue count", because the "Display options" link (where the "Display as" option can then be configured) is greyed out. I can't believe this is by design.

Regards.

Paul

Hi Paul,

I tried to recreate your problem in our environment (Confluence 5.1.3 and Jira 6.0.3) and didn't have the problem, I could select issue count (see attached screenshot) :

This is using the Jira Issues macro, if I use the Jira Issue (without the extra s), I don't get any display options, might that be the problem?

Best regards,

Peter

Hi Peter

Are you sure you're not using a pre-5.0 version of the JIRA Issues macro? Version 5 combined the two macros into just the one (Release Notes). The new macro looks like below (and you can see in this example that I cannot select "Display options" when the query doesn't return anything).

Regards.

Paul

Do'h :( You are right I'm still using the 4.x version.

You still try to get this functionality back using the jira gadgets in confluence, for example, you could take the Filter Result gadget and use the same JQL your using in you example to display the following :

It's still not exactly what you want, but at least you can see that there are currently no results for you filter. This could be a temporary work around.

They should indeed be fixed in the plugin.

Best regards,

Peter

Hi Paul,

You're welcome and good luck :)

Regards,

Peter

Hi Peter

I only have this version of the macro in our Test Confluence/JIRA environment at the moment, so I may just hold off updating it in our Production one until the issue has been resolved.

Alternatively, I will certainly look at the workaround you have proposed.

Many thanks for all your input!

Regards.

Paul

Dear Paul.

We encountered the same issue and as your link is (at least for me) invalid I'd like to ask if you got any information about this.

We haven't upgraded to Confluence 5.2.x (which would use the PluginVersion 5.0.2) and the for us newest valid 5.0 version still seems to have this behaviour.

This is for us a (minor) "Pluginupgradeshowstopper".

Kind regards

Sascha

Hi Sarah

I mistakenly had the fullstop on the end as part of the link. I've now corrected this and you can access it to view the current state of the issue.

Regards.

Paul

Is working now -> Thank you very much!

a convoluted way of working around this... create 2 issues that you move to fit your query, set your macro, and move them back out ( and keep them for the next time you need it).

Filter results isn't ideal, because I only want the total number of issues as well.

what a pain. I use OnDemand, so I have no other great options.

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Published May 30, 2018 in Marketplace Apps

Three tips for boosting your board's efficiency with Story Maps

Trello is one of the most effective tools for driving your sprints. It's customizable for every Agile team and product owners and Scrum masters (SM) love it. However, Agile teams often struggle with:...

850 views 2 9
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you