{{issue.comments.last.body}} not working correctly in HTML email notifications.

Hi,

We are using Automation for JIRA SD cloud and I have currently setup alert email notifications that are set to be HTML.  I'm using {{issue.comments.last.body}} within the body of the email and it is not coming through correctly even though everything is set as HTML.  Only the {{issue.comments.last.body}} field appears to have this issue.   The email come through ok with the other components but as soon as that field value is placed within the email it is showing all HTML tag/formatting as text for any values of that field.

Have you seen this before?  

Thank you,
Larry

1 answer

This widget could not be displayed.

I haven't seen this before but mail clients showing HTML source rather than processed HTML usually occurs if the HTML isn't valid.

Since the comment is used directly by default, you could try escaping the comment? Something like:

{{#htmlEncode}}{{issue.comments.last.body}}{{/}}

should do the trick

Thanks for the reply Mark,

I gave this a shot and unfortunately it was still coming through in the same manner.   I've just changed everything to standard text for now to clean it up.  

Cheers,

Larry

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Aug 22, 2018 in Marketplace Apps

How a Marketplace app tech team is achieving gender diversity

Hello! My name is Genevieve Blanch, and I'm the Marketing Manager at RefinedWiki, creators of apps to give teams the tools to customize Atlassian platforms. Currently, 44% of the tech team at Re...

536 views 3 19
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you