ictime - why I can not log work?

Hello,

we would like to purchase the ictime plugin, but we are having troubles while testing...

We have following issues:

1. User can log work only if he's in a specific groups (jira-users) however user is able to log work after disabling the plugin

- Error message displayed in log work screen: No permission: [user_name]

2. Plugin does not work after disabling and enabling the plugin in plugin manager

3. After reinstalling the plugin we have the same issues

- after reinstalling all settings are recovered

ictime version 2.0.4.

jira version 5.0.2

Thank for your reply

Adrian Zvara

6 answers

Hi Adrian,

Let's try to sort this out..

1.

The error message itself does not come from ictime, but probably from JIRA. However, something is wrong if you are able to log work in JIRA, but not when ictime is enabled (maybe it is not enabled correctly). Could you provide a screenshot and details (from which screen did you choose the option to log work, do you get the message when the screen is displayed, or when trying to submit)?

In general, regarding the permission to log work, ictime relies on JIRA permissions, i.e. time tracking needs to be activated in JIRA and the user needs to have the "work on issues" permission in the applicable JIRA permission scheme. If this is the case, you will be able to log work in JRA (and if ictime is installed and correctly enabled, in ictime). Provided everything is okay here, there are additional requirements in ictime for being able to log work:

  1. The project needs to be active or has no status in ictime (ictime/Configuration/Configure Projects/Edit Project/Status); but this should be the case by default, you don't have to make a setting here.
  2. Either you have deactivated the activity type feature in ictime, or you have created at least one activity type in ictime (ictime/Configuration/Activity Types).
  3. For the project you want to log work on issue, you either have deactivated the team/pricelist feature (ictime/Configuration/Configure Projects/Edit Project/Teams & Price Lists) or you have created a team, assigned the respective user to this team and have created a price list with a validity period.

If this is done, you should be able to log work. If not, you should get specific error messages, telling you that you are not a team member, there is no vald price list, activity type is mandatory etc.

2.

Depending on your JIRA version (5.0.2), you probably have an old version of the Universal Plugin Manager (UPM). There are lots of issues with older versions of the UPM, and not being able to activate plugins again after having disabled the plugin is one of the issues I have already seen with other plugins (but up to now not with ictime). So if possible, upgrade to a current JIRA version and check that the UPM is also up to date. This should definitely fix the issue. I also could imagine that your UPM version is responsible for #1, as I have the suspicion that ictime is not really enabled and running correctly. Can you see the ictime navigation with Timesheet, Configuration menu etc. and acces these items?

3.

I don't think that the installation itself is the problem, so a re-install does probably not help.

However, when you uninstall and re-install, you won't loose your settings, so if you have created activity types, teams etc., they won't be deleted when uninstalling. This is the intended behoviour.

Okay, so maybe you try update JIRA/UPM to see if this solves the problem. If you can't update (or this does not solve the problem), please come back to me again and provide a screenshot, details as requested above (and maybe JIRA logs if you have access to the logs).

Best regards

Tobias

Hi,

I have updated the UPM. The issue was unfortunetally not solved.

I have made some settings screen shots that will explain the issue...

how i've tried to log work. while the ictime plugin is disabled i can log work - no problem.

my JIRA settings

Hi Adrian,

Can't detect anything problematic in your settings, everything looks okay. I have tried to reproduce this problem playing around with ictime and JIRA permissions, but could not generate any problem. If you don't have the respective JIRA permissions, you can't log work in ictime, either. And if you have the JIRA permissions to log work, you do not need any additional ictime permissions to log work via ictime (ictime does not have a separate "log work" permission; you might get different, specific error messages if project or ictime setup is not okay, but this is not the case here).

The error message that you see is coming from JIRA. Do you have access to your JIRA logs and can have a look if something is logged when the message appears?

Another thing you could check: Did you try to log work from other places ictime offers, like the "Log Work" button in "My Timesheet"? Do you get the same message?

Best regards

Tobias

Yes, I've tried to log work from My timesheet but no success. Even if the error message did not appeared work was not loged.

It's a strange behaviour. I'm going to test ictime on a newer version of JIRA if this issue will still appear.

Which log file should I look for?

Hi Adrian,

So you could not log work using the button from "my timesheet", but did not get an error. That also might help us to get closer to the issue. Can you edit existing work logs from the timesheet?

Log is atlassian-jira.log.

You might also want to use ictime 2.1, but I'm relatively sure that there have been no changes regarding this topic compared to version 2.0.4.

Best regards

Tobias

I have opened the log file and a can't see any errors.

Then I've tried to edit my timesheet. Records were created while ictime disabled. Than I enabled the ictime and tried to edit. After submiting the form I get an error:

Now i've tried ictime with new JIRA 5.1.4. and we have the same issue. Nothing new.

Hi Adrian,

I think you forgot to attach the screenshot for the editing case. However - was the error message the same or different?

We have done some more testing, but were neither able to reproduce the error nor to get an idea why it appears. As already mentioned, ictime fully relies on JIRA regarding the "work on issues" permission - if it works in JIRA, it must work in ictime, and if it does not work because of a specific ictime restriction, you get a specific error. Maybe the problem is related to other time tracking tools you have installed, or to custom status and workflows you use. Or your test user (Testovaci) - which seems not to be the same like the one I can see on the screenshot who has logged work successfully (Adrian) - has a configuration problem that the other user does not have. But this is just pure guessing, and if a user does not have permissions (or an issue state does not allow for logging work, like e.g. "closed"), the user should not be able to get the log work mask ...

If your installation only contains test data, you might consider to provide a dump (via email or download) and we could try to test with your data. Don't know if this is an option for you.

Regarding the issue of ictime not getting enabled correctly after disabling, was that solved with the update of JIRA/UPM? We could reproduce this problem with JIRA 5.1.4 + UPM 2.3, i.e. with new versions. What happened is basically that we did not get the extended ictime data and the log work mask was the default JIRA mask that was not working (connection to server error). After trying a couple of times to disable/enable, everything was working again. This problem should be caused by the fact that for more complex plugins that extend existing JIRA functionality, JIRA might fail to reload/initialise extended classes correctly. I have filed an issue in our bugtracker, but don't think that this can be easily solved, as it happens on a much deeper layer where we have no control. If the issue still exists on your side, you might try to disable/enable a couple of times.

Best regards

Tobias

(error.txt) here you have my error message from the editing case...

I think I can provide a dump. Where can I send it to you?

thanks

Hi Adrian,

Before we check the dump, let's try to ensure that ictime is really running properly on your installation. The error message on editing indicates that this is not the case (an ictime class is not found).

Please try the following:

  1. Completely uninstall ictime
  2. Restart JIRA
  3. If you have other time tracking plugins like Tempo installed, deactivate them.
  4. Install ictime again (last version 2.1.1 from 18.09.); via the UPM (search for ictime)
  5. Enter the evaluation license key and directly try to log work in ictime (your settings should still be there).
  6. If it works now, fine. If you get an ictime specific error (no activity type, no pricelist, no team etc.), correct the configuration for the project in ictime and try again. If it works, fine. Go to #7 do do a final check.
  7. If not, check if you find something in the Plugin Audit Log and check in the UPM if ictime really seems to be enabled (you see the "Disable" option). If nothing is found there, we'll have to go for the dump (contact | at | interconcept.de).
  8. If it worked in #6, finally try to disable/enable ictime in the UPM. If it still works after enabling again, fine. If not, try multiple times (and wait a couple of minutes after enabling before using ictime). If this does not help, there is a problem we probably can't address at this moment, as we have no access to these mechanisms in JIRA. As already mentioned, we could reproduce such a behaviour from time to time, but usually it works fine. We already have filed on issue to analyse if there is something on our side that could make it problematic for JIRA to enable correctly, but I assume that the solution could only be found on a layer (JIRA, java, application server, ...) where we have no access.

Best regards

Tobias

Hi,

I followed your steps until step 5. There i could not log work. Although I get message Logged succefully the entry is not inserted.

I'm sending now a dump via email so you can replicated my issue.

Thanks

Hello Adrian,

The problem is identified: You have changed the Global JIRA Permissions so that the permission to log in into JIRA is no longer granted to the group "jira-users", but to another group; and your ictime test user is member of this group, but no longer of "jira-users". This does not work with ictime due to a check we are performing, if a user wants to log work, this user needs to be assigned to the group "jira-users".

We will change this with the next release (~ 2 weeks). In the meantime, for testing purposes, you could assign your test users to the group jira-users and it will work.

Best regards

Tobias

Thanks Tobias.

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Nov 29, 2018 in Marketplace Apps

How to set up an incident workflow from the VP of Engineering at Sentry

Hey Atlassian community, I help lead engineering at Sentry, an open-source error-tracking and monitoring tool that integrates with Jira. We started using Jira Software Cloud internally last year, a...

1,447 views 0 8
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you