I'm not sure if this issue is caused by jira being behind apache (port 80).

Any ideas on how to fix it?

5 answers

Hi Carlitos,

This message ("The JIRA server could not be contacted. This may be a temporary glitch ...") might indicate that a plugin can't be loaded/initialised correctly and does not necessarily mean that there is really a network/configuration issue. You might want to check https://answers.atlassian.com/questions/81075/error-after-upgrade-the-jira-server-could-not-be-contacted. Suggested "solution" in this case is a JIRA restart.

If this does not help, you might also want to check the following issue with the same error message: https://answers.atlassian.com/questions/53961/can-t-supply-license-key-to-greenhopper

Specifically the posts regarding JIRA base URL, DNS resolution and the last one regarding use of a proxy. Maybe one of these helps.

Best regards

Tobias

I've upgraded to latest UPM (2.7.3) and also upgraded to Jira (5.1.5) with the same result. I cleaned the log and started a new one. But it looks like it's a problem on the ictime plugin.

Thanks for the logs. For the moment, I assume that this is the issue (a bug in the JIRA plugin system):

https://jira.atlassian.com/browse/JRA-29386

Your logs shows an exception thrown in ictime that most probably is originating exactly in the DefaultSimpleLinkManager from JIRA and resulting in a (confusing) error message + exception in the log:

java.lang.NullPointerException
	at de.iconcept.ictime.utils.StringUtils.getShortenedDisplayString(StringUtils.java:24)
	at de.iconcept.ictime.factories.RecentWorklogsFactory.getLinks(RecentWorklogsFactory.java:101)
	at com.atlassian.jira.plugin.webfragment.DefaultSimpleLinkManager.getLinks(DefaultSimpleLinkManager.java:190)
	at com.atlassian.jira.plugin.webfragment.DefaultSimpleLinkManager.getLinksForSection(DefaultSimpleLinkManager.java:124)

Atlassian say this is going to be fixed for version 5.1.6. However, we and customers have ictime running with many different combinations of JIRA versions and UPM versions, and it seems unpredictable if and when this problem occurs. So far we have only one report of this error message from July. That's why I'm not absolutely sure if the JIRA issue above is really the root cause, but it seems very probable.

Maybe a new, clean install of a current JIRA version (not updating an existing version) also solves the issue. We will also file an issue in our bugtracker to see if there is something we could change on our side to avoid the problem.

Hi Tobias,

Most appreciated for the info. I will wait for 5.1.6 impatiently. Not sure about the clean install. The upgrade seems to replace everything in my jira as I have to copy modified files over again.

I definitely want to use your plugin. Currently, I can only access this one:

http://mydomain/secure/ICTimeBrowseTimeEntries!default.jspa

In some Jira Issues I can access the Resume Work Log as follows:

http://mydomain/secure/CreateWorklog!default.jspa?id=14501&worklogId=14500&resume=1

or

http://mydomain/secure/UpdateWorklog!default.jspa?id=14501&worklogId=14500

Can you tell me the other plugin "pages" (not sure if that's what is called) so that I can configure and test it out? I am refering to the *.jspa pages.

Thanks in advance!!!

Carlitos

These are all the pages:

My Timesheet

/secure/ICTimeBrowseTimeEntries!default.jspa

Reporting, Accounting

/secure/ICTimeCreateReportAction!default.jspa

/secure/ICTimeBrowseInvoices!default.jspa

Planning, Plan/Actual

/secure/ICTimePlanProject!default.jspa

/secure/ICTimeCompareProject!default.jspa

Configuration

/secure/ICTimeBrowseActivityTypes!default.jspa

/secure/ICTimeBrowseRoundingRules!default.jspa

/secure/ICTimeBrowseProjects!default.jspa

/secure/ICTimeSecurity!default.jspa

The last one can be used to define the permissions. If you are in groups jira-administrators and jira-developers, you should be able to access all functionality without additional configuration.

If those links work that would mean that ictime in fact is loaded and initialised correctly, only the navigation throws an exception that leads to the confusing message (and the webpanel on the issue page throws an exception, too). We will have a more detailed look at this within the next days. Please just confirm if you can really use the pages.

Thanks!!! Exactly what I needed while this (that looks like a Jira bug) gets fixed.

Forgot to confirm that i am able to see all the pages you sent me.

Hi Carlitos,

As it seemed very weird that you get the exceptions, but can use all pages of ictime, we have done some further research and found a possible problem on ictime side. We could partly reproduce your errors in case of a NULL value for the work log description (not empty, which is okay, but really NULL) in the database. This should not happen, but could maybe happen. I will send you a link with an (inofficial) version of ictime that fixes this issue. Just uninstall ictime and install this version. If this fixes your issue, the problem was not a JIRA/plugin system issue, but an incorrect handling of an unexpected NULL value on ictime side.

Best regards

Tobias

Hi Tobias,

Your patch works!!! I'm now able to see the ictime menu (screenshot below).

Also, keep in mind this suggestion for the guys using Fisheye Smart Commits as I'm doing. For example, this was my last commit:

#comment Added validation OnSaving for ReportLog and SqlQueryLog. An exception will be thrown if these objects are not setup properly in the Execute Method. #time 30m #resolve

The time log was added into Jira, but the description was empty for ictime log. The #comment section should be grabbed and added into the description of ictime.

It would be great if you can enable this feature. Otherwise I'll have to stop using #time thing at the Smart Commits.

Thank you!!!

Hi Carlitos,

Perfect! So our initial idea was wrong, this is not a JIRA plugin system issue and the issue is solved on ictime level (resp. will be officially solved with version 2.1.2 to be released beginning of October).

Regarding Fisheye, I have filed a feature request for this (https://interconcept.atlassian.net/browse/ICTIME-86).

Best regards

Tobias

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Bridget Sauer
Published yesterday in Marketplace Apps

Calling all developers––You're invited to Atlas Camp 2018

 Atlas Camp   is our developer event which will take place in Barcelona, Spain  from the 6th -7th of   September . This is a great opportunity to meet other developers and get n...

66 views 0 5
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you