atlas-create-jira-plugin Command Error

Hi everyone. I am new to Atlas and I am following the following tutorial on creating a plugin for Atlas, but I keep getting an error.  https://developer.atlassian.com/docs/getting-started/set-up-the-atlassian-plugin-sdk-and-build-a-project/create-a-helloworld-plugin-project

 

When I run the command "atlas-create-jira-plugin," the following error occurs. 

[INFO] ------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 2.243 s
[INFO] Finished at: 2017-07-20T09:40:53-05:00
[INFO] Final Memory: 13M/416M
[INFO] ------------------------------------------------------------------------
[ERROR] Failed to execute goal com.atlassian.maven.plugins:maven-jira-plugin:6.2
.11:create (default-cli) on project standalone-pom: Execution default-cli of goa
l com.atlassian.maven.plugins:maven-jira-plugin:6.2.11:create failed: Plugin com
.atlassian.maven.plugins:maven-jira-plugin:6.2.11 or one of its dependencies cou
ld not be resolved: Failed to collect dependencies at com.atlassian.maven.plugin
s:maven-jira-plugin:jar:6.2.11 -> com.atlassian.maven.archetypes:jira-plugin-arc
hetype:jar:6.2.11 -> org.twdata.maven:mojo-executor:jar:1.5.2 -> org.apache.mave
n:maven-artifact:jar:3.2.1 -> org.codehaus.plexus:plexus-utils:jar:3.0.17: Faile
d to read artifact descriptor for org.codehaus.plexus:plexus-utils:jar:3.0.17: C
ould not transfer artifact org.codehaus.plexus:plexus-utils:pom:3.0.17 from/to a
tlassian-public (https://maven.atlassian.com/repository/public): maven.atlassian
.com: Unknown host maven.atlassian.com -> [Help 1]                                             

 

 This is my atlas version. 

ATLAS Version: 6.2.14
ATLAS Home: C:\Applications\Atlassian\atlassian-plugin-sdk-6.2.14
ATLAS Scripts: C:\Applications\Atlassian\atlassian-plugin-sdk-6.2.14\bin
ATLAS Maven Home: C:\Applications\Atlassian\atlassian-plugin-sdk-6.2.14\apache-m
aven-3.2.1
AMPS Version: 6.2.11
--------
Executing: "C:\Applications\Atlassian\atlassian-plugin-sdk-6.2.14\apache-maven-3
.2.1\bin\mvn.bat" --version -gs C:\Applications\Atlassian\atlassian-plugin-sdk-6
.2.14\apache-maven-3.2.1/conf/settings.xml
Java HotSpot(TM) 64-Bit Server VM warning: ignoring option MaxPermSize=256M; sup
port was removed in 8.0
Apache Maven 3.2.1 (ea8b2b07643dbb1b84b6d16e1f08391b666bc1e9; 2014-02-14T12:37:5
2-05:00)
Maven home: C:\Applications\Atlassian\atlassian-plugin-sdk-6.2.14\apache-maven-3
.2.1\bin\..
Java version: 1.8.0_131, vendor: Oracle Corporation
Java home: C:\Program Files\Java\jdk1.8.0_131\jre
Default locale: en_US, platform encoding: Cp1252
OS name: "windows 7", version: "6.1", arch: "amd64", family: "dos"

 

 

I've tried looking online for how to fix this, but to no avial. If any other information is needed, let me know. 

Thank you. 

 

0 answers

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Oct 11, 2018 in Marketplace Apps

You + one app + a desert island...

Hi all! My name is Miles and I work on the Marketplace team. We’re looking for better ways to recommend and suggest apps that are truly crowd favorites, so of course we wanted to poll the Community. ...

2,052 views 5 6
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you