Zephyr jira plugin - after install "Test steps are loading" hangs

Hi,

I've recently installed Zephyr 2.0 jira pluin on Jira 6... When I create a test... The Test details aren't fully loading ... I recieve a spinner and "Test steps are loading" - They never actually load.

I've tried restarting Jira and I'm not able to see anything in the logs ..

Any ideas? Has anyone else seen this / know of a resolution?

Thanks in advance

Alan

17 answers

Hi Alan,

Are you using JIRA 6.0 or 6.1?

Also, have you re indexed JIRA and then Zephyr in that order? In order to do a Zephyr re index go to Administration>Manage Ad On's>Zephyr for JIRA>General configuration page. The Zephyr re index is in there.

Kind Regards,

Emily

Hi Emily,

Thanks for your response.

I had re-indexed Jira initially but hadn't done so for Zephyr... I did that and I'm still getting the same result.

I'm running :

Jira : 6.0.4

Zephyr :

2.0.0.1416

Thanks

Hi,

I just installed the latest version of zephyr which included a bug fix. version: 2.0.1.1426

[Fixed support for web proxies]

Which seems to have resolved the issue.

Regards,

Alan


Hi Alan,

My next step was to have you install the the latest verson that invluded a bug fix. It looks like that did the trick for you!

Kind Regards,

Emily

Hi

We have the same issue, unfortunately we already have installed version 2.0.1.1426. The application worked fine for more than one week, and suddenly today there is no possible to work anymore with the plugin. When you try to open any Zephyr ticket, they are blocked with the message 'Test step are loading'.

Our administrators resolved the issue by disable and enable back the plugin. Anyway there is not clear why this situation apeared.

Regards

Tamara-Loreta

Hi Tamara,

We are looking into this issue now. We do also know that re starting the JIRA server will solve the issue. We are hoping to figure out why this is happening soon. Thank you!

Kind Regards,

Emily

Hi Emily,

We got the same issue...

Please advise the impact of disabling the Zephyr add-on and enable it again. I just want to make sure that we will not lose any data.

Please advise.

Regards,

Jag

Hi Jagath,

You can uninstall and re install Zephyr for JIRA as many times as you want. The Zephyr for JIRA data is stored in the JIRA DB so as long as you have Zephyr for JIRA installed it can access that data. Unless the JIRA DB is compromised your Zephyr for JIRA data is safe.

If you are getting the spinning wheel again when trying to open a test case, can you please try re starting your JIRA? Does this help? We are also looking into this issue heavily right now.

Kind Regards,

Emily

Jag,

There isn't any danger in loosing data. When you disable the plugin, you loose access to test related steps and results, but you regain the access when you enable the plugin once again.

Kind Regards,

Chris

Hi Chris,

today the issue happend again. It was resolved again by enable, disable plus today entire JIRA was restarted. I hope that will not happend again tommorow. Anyway do you know if somebody is analysing this issue and searching for a different solution?

Thanks

Tamara-Loreta

Tamara,

Other companies are experiencing this so we need to resolve it. Also, try clearing your browser cache next time to see if it offers a fix that last longer than disabling and reenabling the plugin.

Hi,

If anyone has upgraded ZFJ 2.0.1.1426 and is still seeing the issue, please clear your browser history/cache and then try again. If it still persists, please contact us in support@getzephyr.com directly so we can investigate it with you.


Kind Regards,
Chris

This is definitely still happening for us :( I've contacted you via your support form.

UPDATE: clear browser history/cache does work. But is a terrible solution, as we now need to communicate this to everyone using JIRA, including people in other companies. So represents an ongoing 'fun task' for us.

A new version that didn't require a cache clear would be a huge improvement for us.

Hi all,

for us, after enable/disable + restart JIRA, the issue did not repeat today.

Still waiting to see what will happen tommorow.

Regards

Tamara-Loreta

Hello Everyone,

This is our current solution to the issue at hand. We know it is not the best, but it is what will work until we come up with a real solution:

http://community.yourzephyr.com/viewtopic.php?f=13&t=1214

Kind Regards,

Emily

Hi all,

We had the same problem twice in one week. Our version of JIRA is 5.1.4#783-sha1:a7d8d2c.
The problem happened for all users and on all browsers (Chrome, Firefox, IE) Clearing the browser cache as adviced by Zephyr, didn't help. Also none of the Zephyr Gadgets produced any data/statistics.

  • The first time it occurred, our plugin version was Zephyr for JIRA 2.0.0.1426.
    We installed version 2.0.1.1426, re-indexed JIRA and re-indexed Zephyr to fix the problem.
  • The second time (with version 2.0.1.1426), re-indexing JIRA and Zephyr as described above didn't help. Even when re-indexing Zephyr, there was the spinning wheel staying on top all the time.
    Disabling and re-enabling Zephyr didn't help either.

    FInally, the problem was resolved by re-installing the same version (2.0.1.1426) over the already installed version (followed by re-indexing JIRA and Zephyr).

Our plugins are installed via the Upload Plugin link and not via UPM.

Regards,

Marc


Hi Everyone,

Just wanted to let you guys know that we released Zephyr for JIRA 2.1. Feel free to upgrade and tell us how it is working for you. Also, this version is compatible with JIRA 6.1. It is now available on the Atlassian Marketplace:

https://marketplace.atlassian.com/plugins/com.thed.zephyr.je

Kind Regards,

Emily

I upgraded from Zerphyr 2.0.1.1426 to 2.1.0.1459 and the problems went away.

We were seeing this in a select user basis here. Our fix was the browser itself to clear the cache and/or force reload of the background JavaScript (jQuery strikes again).

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Thursday in Marketplace Apps

You + one app + a desert island...

Hi all! My name is Miles and I work on the Marketplace team. We’re looking for better ways to recommend and suggest apps that are truly crowd favorites, so of course we wanted to poll the Community. ...

1,495 views 4 6
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you