Zephyr : Errors occur importing from Excel for Version.Affects Version field

When using the ZFJ importer utility to import test cases & steps from excel, an error occurs in the import utility (see below in bold).  The issue is that "Affects Version" is not a field on the importer dialog and the "Versions" field already has a value.  So what does this error really mean?  BTW, I have confirmed that the values in column H are valid.  See attached screenshot. zephyr1.jpg

Tue Aug 18 15:18:30 EDT 2015 Unable to add testcase ending at rowNumber - 5. Error:Unexpected response code: 400 {"errorMessages":[],"errors":{"versions":"Affects Version/s is required."}}

 

 

4 answers

This widget could not be displayed.

Hello Pamela,

I would suggest you to raise a support ticket with us by accessing through the below link. So that we can schedule a screen share meeting to troubleshoot the issue.

https://support.getzephyr.com/hc/en-us

 

Regards,

Zephyr Support.

 

OK thanks will do. I would like to get this import working soon!

This widget could not be displayed.

Do the "Versions" in your spreadsheet match the "Versions" available in Zephyr if you were to manually create a test case and select a Version from the Affects Version/s field?

Otherwise I would just import without the version and bulk update it in JIRA.  If it is a required field, make it un-required while you import and switch it back when you are done.

Yes, the version in the spreadsheet matches the "Affects Versions" values available in Zephyr, if creating a new test case manually. The create new test case form does not have a field for "Version", but the zephyr importer tool does. I assumed the "Versions" from the importer tool would populate "Affects Version" and "Fix Version". The create new test case form only has fields for "Affects Version" & "Fix Version". I will have to get an admin to help with making the field non required when importing.

This widget could not be displayed.

Hello Pamela,

 

Could you please confirm whether the Version,Assignee and Assigned Tester fields are available in create issue screen. You can verify it while creating a  new test.  If those fields are not available then please follow the below steps to add them in create issue screen.

1.Navigate to the particular project.

2.Click on project administration -> Screens

3. Click on the particular screen associated with create issue operation and add Version,Assignee and Assigned Tester fields.

If you are still getting the same error then please raise a support ticket with us by accessing through the below link.

https://support.getzephyr.com/hc/en-us

 

Regards,

Zephyr Support.

This widget could not be displayed.

The Assignee and Assigned Tester fields are available, as well as "Affect Version" and "Fix Version", but there is no field on the create ne test form called "Version".  I thought the error was complaining about "Affect Version" though??  I don't seem to have permissions to add fields to the form.

 

":{"versions":"Affects Version/s is required."}}

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Aug 22, 2018 in Marketplace Apps

How a Marketplace app tech team is achieving gender diversity

Hello! My name is Genevieve Blanch, and I'm the Marketing Manager at RefinedWiki, creators of apps to give teams the tools to customize Atlassian platforms. Currently, 44% of the tech team at Re...

478 views 3 17
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you