Work Calendar does not show any worklogs - stopped working after update

As per title, I updated https://marketplace.atlassian.com/plugins/my_work_calendar today which we have bought a license for and all days are now empty, when they should not be. And I can see time logs everywhere else. And the filters and users are exactly as they were before. 

I even restarted the whole JIRA server machine, but to no avail.

Possibly related to same cause as another add-on became empty same time: https://kintosoft.atlassian.net/browse/LH-20

Tried clearing cache many times but no help. Tried different browser, still no use. 

Also, downgraded to previous version 2.2.2.1 by Uninstalling 2.3 and then downloading https://marketplace.atlassian.com/download/plugins/com.romexsoft.worklogcal.jira-worklogcal/version/344 and then installing the jar through upload - still same problem, everything is empty, no work logs shown for any date under My Work (when the rest of JIRA and other add-ons see the worklogs fine)

 

Client-Side

Now when I enabled FireBug in FireFox while opening the My Work window I did not see any errors either (except one to do with HipChat). I see something like the following. This seems like a good place to find the issue, but I'm not sure where to look exactly?

 
== EventsProvider._parseWorklogs: worklogsArr.length = 40
app.js?...2.2.2.1 (line 1)

== EventsProvider._parseJiraJSON.handleWorklog: issue.key = ENTS-23
app.js?...2.2.2.1 (line 1)

== EventsProvider._parseWorklogs: worklogsArr.length = 15
app.js?...2.2.2.1 (line 1)

== EventsProvider._parseJiraJSON.handleWorklog: issue.key = ENTS-22
app.js?...2.2.2.1 (line 1)

== EventsProvider._parseJiraJSON.handleWorklog: separate REST worklog call
app.js?...2.2.2.1 (line 1)

== EventsProvider._parseWorklogs: worklogsArr.length = 21
app.js?...2.2.2.1 (line 1)

== EventsProvider._parseJiraJSON.handleWorklog: issue.key = ENTS-3
app.js?...2.2.2.1 (line 1)

== EventsProvider._parseWorklogs: worklogsArr.length = 5
app.js?...2.2.2.1 (line 1)

== EventsProvider._parseJiraJSON.handleWorklog: issue.key = BREAD-30
app.js?...2.2.2.1 (line 1)

== EventsProvider._parseWorklogs: worklogsArr.length = 2
app.js?...2.2.2.1 (line 1)

== EventsProvider._retrieveJSON, success: that._total, that._startAt, that._maxResults = 21, 0, 1000
app.js?...2.2.2.1 (line 1)

== EventsProvider._retrieveJSON, calling callbackFun

 

Server-Side JIRA Startup Errors

JIRA logs seem to be of no use here: when I opened My Work none of the logs files changed at all. Same when I used the refreshed cache button - nothing added to the JIRA log files.

I also cleaned the log files and then restarted server to see if there are any errors: everything to do with work calendar add-on shows no problems and there were only two (probably unrelated) exceptions in the whole log file (appended below).

2015-06-06 09:49:05,772 localhost-startStop-1 ERROR [atlassian.plugin.loaders.ScanningPluginLoader] Unable to deploy plugin 'null' from 'Unit: C:\Program Files (x86)\Atlassian\Application Data\JIRA\plugins\installed-plugins\plugin.7741075696196267751.jira-greenhopper-plugin-6.6.70.jar (1426068081322)'.
2015-06-06 09:49:05,772 localhost-startStop-1 ERROR [atlassian.plugin.loaders.ScanningPluginLoader] Because of the following exception:
com.atlassian.plugin.PluginParseException: Cannot open JAR file: C:\Program Files (x86)\Atlassian\Application Data\JIRA\plugins\installed-plugins\plugin.7741075696196267751.jira-greenhopper-plugin-6.6.70.jar
at com.atlassian.plugin.JarPluginArtifact.open(JarPluginArtifact.java:214)
at com.atlassian.plugin.JarPluginArtifact.getResourceAsStream(JarPluginArtifact.java:82)
at com.atlassian.plugin.osgi.factory.OsgiPluginFactory.getDescriptorInputStream(OsgiPluginFactory.java:133)
at com.atlassian.plugin.factories.AbstractPluginFactory.hasDescriptor(AbstractPluginFactory.java:64)
at com.atlassian.plugin.osgi.factory.OsgiPluginFactory.canCreate(OsgiPluginFactory.java:120)
at com.atlassian.jira.plugin.MasterPluginFactory.canCreate(MasterPluginFactory.java:52)
at com.atlassian.plugin.loaders.ScanningPluginLoader.deployPluginFromUnit(ScanningPluginLoader.java:152)
at com.atlassian.plugin.loaders.ScanningPluginLoader.loadAllPlugins(ScanningPluginLoader.java:89)
at com.atlassian.plugin.loaders.PermissionCheckingPluginLoader.loadAllPlugins(PermissionCheckingPluginLoader.java:24)
at com.atlassian.plugin.manager.DefaultPluginManager.earlyStartup(DefaultPluginManager.java:338)
at com.atlassian.jira.plugin.JiraPluginManager.earlyStartup(JiraPluginManager.java:97)
at com.atlassian.jira.plugin.JiraPluginManager.start(JiraPluginManager.java:87)
at com.atlassian.jira.ComponentManager$PluginSystem.start(ComponentManager.java:767)
at com.atlassian.jira.ComponentManager.quickStart(ComponentManager.java:258)
at com.atlassian.jira.ComponentManager.start(ComponentManager.java:232)
at com.atlassian.jira.upgrade.PluginSystemLauncher.start(PluginSystemLauncher.java:29)
at com.atlassian.jira.startup.DefaultJiraLauncher$3.run(DefaultJiraLauncher.java:135)
at com.atlassian.jira.config.database.DatabaseConfigurationManagerImpl.doNowOrEnqueue(DatabaseConfigurationManagerImpl.java:324)
at com.atlassian.jira.config.database.DatabaseConfigurationManagerImpl.doNowOrWhenDatabaseActivated(DatabaseConfigurationManagerImpl.java:214)
at com.atlassian.jira.startup.DefaultJiraLauncher.postDbLaunch(DefaultJiraLauncher.java:118)
at com.atlassian.jira.startup.DefaultJiraLauncher.access$100(DefaultJiraLauncher.java:32)
at com.atlassian.jira.startup.DefaultJiraLauncher$1.run(DefaultJiraLauncher.java:81)
at com.atlassian.jira.util.devspeed.JiraDevSpeedTimer.run(JiraDevSpeedTimer.java:34)
at com.atlassian.jira.startup.DefaultJiraLauncher.start(DefaultJiraLauncher.java:76)
at com.atlassian.jira.startup.LauncherContextListener.contextInitialized(LauncherContextListener.java:71) <+5> (StandardContext.java:4992) (StandardContext.java:5490) (LifecycleBase.java:150) (ContainerBase.java:1575) (ContainerBase.java:1565)
at java.util.concurrent.FutureTask.run(FutureTask.java:266)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
at java.lang.Thread.run(Thread.java:745)
Caused by: java.util.zip.ZipException: error in opening zip file
at java.util.zip.ZipFile.open(Native Method)
at java.util.zip.ZipFile.<init>(ZipFile.java:220)
at java.util.zip.ZipFile.<init>(ZipFile.java:150)
at java.util.jar.JarFile.<init>(JarFile.java:166)
at java.util.jar.JarFile.<init>(JarFile.java:130)
... 33 more
2015-06-06 09:51:09,294 localhost-startStop-1 ERROR [atlassian.activeobjects.osgi.ActiveObjectsServiceFactory] Didn't find any configuration service for bundle com.atlassian.jira.plugins.webhooks.jira-webhooks-plugin nor any entities scanning for default AO packages.
2015-06-06 09:51:09,294 localhost-startStop-1 ERROR [atlassian.event.internal.AsynchronousAbleEventDispatcher] There was an exception thrown trying to dispatch event '[com.atlassian.plugin.event.events.PluginEnabledEvent@1e261a2, SingleParameterMethodListenerInvoker{method=public void com.atlassian.webhooks.plugin.WebHookEventsProcessor.onEvent(java.lang.Object), listener=com.atlassian.webhooks.plugin.WebHookEventsProcessor@38a680}]' from the invoker 'java.lang.RuntimeException: Didn't find any configuration service for bundle com.atlassian.jira.plugins.webhooks.jira-webhooks-plugin nor any entities scanning for default AO packages.'

 

Version 2.2.2 Works

I thought I'd try one version earlier, and so I uninstalled 2.2.2.1 and installed 2.2.2 - and it works fine! So the issue arises from some changes in 2.2.2.1 

 

2 answers

Hello Appywell Apps,

Could you please help me to find the problem.

  1. Please send me atlassian-jira.log file: https://confluence.atlassian.com/display/JIRA/Logging+and+Profiling
  2. Tell me you JIRA version.
  3. Tell Work Calendar version you upgraded from

please see edits to the question - how to troubleshoot further?

using Work Calendar 2.2.2.1 now (as thought that might fix the issue but it didn't); and JIRA Build : 6.3.15#6346

discovered that 2.2.2 shows the logs nicely - see last edit

Thank you for detailed error report. Only suspicious thing is ActiveObjects related error. Starting from version 2.1 Work Calendar uses ActiveObjects atlassian API. Difference between 2.2.2.1 and 2.2.2 is very minor and I really do not see a place that can cause the problem. Few JavaScript lines were changed and no Java changes at all. Could you please send me full atlassian-jira.log to email: support at jira-work-calendar.com so I can look through it if there crashes for Work Calendar addon.

Hi  Appywell Apps,

Just released version 2.4 that includes fix for "No worklogs" problem.

Please be aware that during next 2 weeks I will be merging Server and Cloud versions of the Work Calendar. This requires recreation of the Work Calendar marketplace listing. Since it will be a new marketplace listing, you will need to uninstall the current version and install the new one. I will contact you with detailed instructions.

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Nov 29, 2018 in Marketplace Apps

How to set up an incident workflow from the VP of Engineering at Sentry

Hey Atlassian community, I help lead engineering at Sentry, an open-source error-tracking and monitoring tool that integrates with Jira. We started using Jira Software Cloud internally last year, a...

1,137 views 0 8
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you