Which version of Java does the mutliexcerpt plugin (version 4.3.1) support?

I installed Confluence on top of JDK 1.7 and the Multiexcerpt plugin (version 4.3.1) cannot be enabled. Is it the case that the plugin reuires JDK 1.6 and will not run under 1.7?

3 answers

1 accepted

0 votes
Accepted answer

Yes, the latest version of the plugin solves the issue with Java 1.7.

Note for those who use Confluence with Crowd. The latter must be upgraded to the latest version if needs to run with Java 1.7 as well.

Hi,

Thanks for reaching out on this. A couple of other people have experienced this as well.

Certainly nothing in the plugin itself is dependent on JDK 1.6.

I did some searching and found these similar sounding issues:

https://jira.atlassian.com/browse/CWD-2967

https://jira.atlassian.com/browse/FE-3916

https://ecosystem.atlassian.net/browse/PLUG-866

Can you try clearing the Confluence plugin cache? Here is documentation on how to do this:

Please let me know if this fixes the issue!

thanks,

Brendan

Version 4.5 of the plugin now definitely supports Java 1.6 and 1.7.

I revamped the deployment model and in so doing I did find what was causing the plugin to choke on Java 7.

Version 4.5 of the plugin (current at the moment) definitely fixes this.

thanks,

Brendan

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Feb 07, 2019 in Marketplace Apps

A Timeless Love Story

It started as any story starts, on a normal, rainy day.   Admin meets App, and her name was Klok2, and like any first relationship we were both trying to make it work but neither one knew what...

457 views 8 27
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you