Very Long Tomcat-startuptime with Confluence EAR-WAR Edition

Hello

I have a serious problem with Tomcats startuptime and the Confluence EAR-WAR Edition.
Everything worked perfect when I was using Ubuntu and my VM but now, since I want to install Confluence on a software development environment with OpenSuse there seems to be a big problem.

java.runtime.version 1.6.0_24-b24
java.vm.name OpenJDK 64-Bit Server VM
Tomcat6
Confluence EAR-WAR Edition 4.3

Everytime I start Tomcat with "/etc/init.d/tomcat6 start" processing stops for a ling time at the following line:

2012-09-13 17:10:19,431 INFO [main] [atlassian.plugin.manager.DefaultPluginManager] init Initialising the plugin system

It takes about 30-40 minutes and then the startup continues.
Afterwards Confluence look like it is working, but some of the plugins are not installed (e.g. Plugin Manager). You can also get this information from the log:

2012-09-12 12:04:44,576 INFO [main] [atlassian.plugin.manager.DefaultPluginManager] init Initialising the plugin system
2012-09-12 12:33:41,975 INFO [main] [atlassian.plugin.manager.DefaultPluginManager] notifyPluginDisabled Disabling com.atlassian.confluence.plugins.confluence-sal-plugin
2012-09-12 12:33:42,013 INFO [main] [atlassian.plugin.manager.DefaultPluginManager] notifyPluginDisabled Disabling confluence.aui.staging
2012-09-12 12:33:42,014 INFO [main] [atlassian.plugin.manager.DefaultPluginManager] notifyPluginDisabled Disabling com.atlassian.auiplugin
2012-09-12 12:33:42,016 ERROR [main] [atlassian.plugin.manager.PluginEnabler] actualEnable Unable to start the following plugins due to timeout while waiting for plugin to enable: com.atlassian.confluence.plugins.confluence-sal-plugin,confluence.aui.staging,com.atlassian.auiplugin
2012-09-12 12:33:42,022 INFO [main] [atlassian.plugin.manager.DefaultPluginManager] init Plugin system started in 0:28:57.444

I first thought it might be a problem with the memory settings, but since I now tried nearly all possible combinations with -Xmx, -Xms, PermSize, etc. JAVA_OPTS in catalinga.sh, I think the problem is somewhere else...

I know from my VM that it usually takes something like 2-3mins to start Tomcat including confluence etc.

Does anyone have an idea what might be the problem here?

Regards,

Kai

1 answer

Hi Kai,

I do have Confluence 4.3 standalone (not EAR/WAR) on my lab environment, which operational system is OpenSUSE 12.2 with encrypted volume groups and Oracle JDK 1.6.35. It boots in about 3 minutes (Xmx = 1GB). So would you try to reproduce your tests using Oracle JDK 1.6.26 or higher? OpenJDK is not supported by Atlassian and causes many misbehaviors in our products. I believe that it may be the case.

Best regards,
Lucas Timm

Hey Lucas,

thanks for your quick response.

Unfortunately, switching to Open JDK is not an option on our server
My Ubuntu-Server (local VM) runs with Open JDK RE (IcedTea7 2.3.2) (7u7-2.3.2-1ubuntu0.12.04.1) and I didn't have any problems installing Confluence....
The software development environment runs with OpenJDK RE (IcedTea6 1.11.1) (suse-3.1-x86_64)

I now also tried the standalone-version (which comes with its own Tomcat) on the software development environment and the same problem comes up again. The "new" Tomcat pauses for about 30-40 mins at

INFO [main] [atlassian.plugin.manager.DefaultPluginManager] init Initialising the plugin system

...

Regards,

Kai

Well I set up a Virtual Machine with OpenSuse 12.1 and the same openjdk Version 1.6.0_24-b24.

The standalone package of Confluence worked without any problems. I started the bundled Tomcat and everything was working within a couple of seconds....

Any further ideas what might block/slow down the initialisation of the plugin system on the other mashine?

Regards,

Kai

Hi again Kai,

This is interesting. I have already upgraded all my OpenSUSE 12.1 boxes to 12.2, so I can no longer compare its default configurations. However, you can compare the Kernel settings between OpenSUSE 12.1 and OpenSUSE 12.2. Check the outputs of "sysctl" in both.

Indeed, there is no chance of you installing an Oracle JDK in your openSUSE 12.2 box? You don't need to set it to the whole system. You can use the .bin Oracle JDK installer (not the RPM one) and uncompress it under /opt/atlassian/jdk or something like that. Looking forth, edit the JIRA setenv.sh file and point the JAVA_HOME variable to this directory. This way only JIRA will use the Oracle JDK, the whole system will keep using IcedTea.

I hope it helps.

Best regards,
Lucas Timm

Do what Lucas told you. You can have as many JDKs you want on a system. My ubuntu runs: 1.5 (ORCL) / 1.6 (ORCL/OPEN) / 1.7 (ORCL)

Same as me, Radu. I do have Oracle JDK 1.7 to the system (and Confluence), 1.6 for JIRA, 1.5 for legacy apps and OpenJDK for nothing :) (I just keep it because it is installed by default).
I manage all of them using "alternatives" command, but for Atlassian software, I only set the JAVA_HOME variable.

Thanks for your help!

I downloaded and unpacked the Oracle jdk1.7.0_07. Afterwards I changed the JAVA_HOME settings for the Tomcat/Confluence...
It now starts with Oracle jdk1.7.0_07, but I still get the same problem....

To be honest I am not quite sure how to look at the "sysctl" output and what of all these parameters might have an impact on the initialisation of the Confluence Plugin system...

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Oct 11, 2018 in Marketplace Apps

You + one app + a desert island...

Hi all! My name is Miles and I work on the Marketplace team. We’re looking for better ways to recommend and suggest apps that are truly crowd favorites, so of course we wanted to poll the Community. ...

3,033 views 6 6
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you