UseTFS suddenly stopped scanning

I am new to using JIRA (Download), I don't know why but the UseTFS just suddenly stopped scanning.

0. Both JIRA and TFS are individually working fine. The sync was working fine for 2 days, both direction sync TFS <-> JIRA.

1. Whenever I created an new issue in JIRA, then when I opened the WorkSynchronizer logs, the line "JIRA issues awaiting in queue since last synchronization" is showing a non-zero number 1/2/3/etc. Then after one minute, it dropped to "0" and nothing - no log, no error, just nothing - "No log entries".

2. the com.pigsty.jira.plugins.usetfs.revision.RevisionIndexer:job is set to 1 (I have never touched that).

3. "Connection Status" is Active.

4. I already tried disable then enable UseTFS, no luck

5. I already tried uninstall and then install again, no luck

6. The "Last scanned time" never updated anymore, and it has been "Wed Dec 31 19:00:00 EST 1969" since I reinstalled.

7. I am using the sample synchronizer.xml

8. I already tried to re-add the TFS repository.

Since there is no log I don't even know how to troubleshoot it.

Any clue?

1 answer

1 accepted

Can you try restarting your JIRA instance? Also you can increase logging level - refer to answer here https://answers.atlassian.com/questions/128835/required-tfs-fields?page=1#comment-130974

Yes I have tried restarting the JIRA but still no luck. Actually, I already tried rebooting both the JIRA machine and the TFS machine.

I followed the "HACK" instruction on your link and here is the the log file (C:\usetfs-jira.log):

http://67.199.105.135/usetfs-jira.log.txt

I created an JIRA issue at around 2013-01-31 10:28, then I started to see some exceptions in the log files.

() hmmm the attachment didn't went through, trying again.

by looking at the log, i see something like "... Exception while indexing ... "

Should I go to the JIRA->Advance->Re-index and reindex the JIRA?

To help you to help me, here is some extra info...:

1. I have been working on making my own synchronizer.xml - the JIRA sync was fine, also the JIRA logs was fine and recording errors, until then suddenly it just stopped creating log.

2. I have added custom fields (text field and drop down) into JIRA issue, again, the custom fields were once working and syncing fine.

3. I updated the UseTFS client to 2.4.1 (by running the wyUpdate.exe, it is showing "the latest already installed)

4. The UseTFS client is showing that the Reponsitory UUID is something like '0b911aa0-186d-4d1f-****-*************'

5. I tried to reindex changeset AFTER the scanning has stopped.

6. The system only have 2 users now.

7. UseTFS is the only plugin so far (except for any default plugins)

8. I have tried using certain different login/password under the JIRA->TFS responsitory AFTER the scanning has stopped. I also intended a wrong crendital then the JIRA did returned connection error.

Hi Mike,

UseTFS indexing doesn't have anything to do with JIRA indexes so re-indexing won't help.

Can you try with this unreleased version http://www.pigsty.com.pl/downloads/usetfs-2.4.2.jar - we susspect a bug in TFS SDK. Let me know if that works for your.

To update you a bit:

1. I installed the 2.4.2 into JIRA and the logs started coming back, thx!

2. I did not change any other configurations other than installing the 2.4.2

3. I did NOT update the UseTFS client.

4. I rolled back the synchronizer.xml to my custom one I have before, it is still working fine, the TFS and JIRA are now syncing in both direction, thx!

Now, I think the question is, should I use this unreleased version? Or I should wait until it is offically released? When will be the offical release date of 2.4.2 by the way?

Great to know that you're up and running with UseTFS. No need to update UseTFS client it's compatible (besides 2.4.2 is an "ad-hoc" package and contains 2.4.0 client) not much changed between 2.4.0 and 2.4.1 since 2.4.1 was hot fix release. Stay with the unofficial one until we release 2.4.3 or higher (2.4.2 will be skipped as some customers including you got it, and then you would not be notified about upgrade possibilit if 2.4.2 with other changes appeared on marketplace).

I'm not sure when we'll release next one, could be next week, probably within max of 1 month (we need to trace down the issue in TFS SDK, for now we only have a workaround). Anyway the unofficiall one you got is 100% and fully functional.

Ok thx a lot! I appreciate your help!

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Bridget Sauer
Published Thursday in Marketplace Apps

Calling all developers––You're invited to Atlas Camp 2018

 Atlas Camp   is our developer event which will take place in Barcelona, Spain  from the 6th -7th of   September . This is a great opportunity to meet other developers and get n...

365 views 0 6
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you