Upgraded JIRA to 5.1.2 and now subversion plugin can't authenticate. Are there any authentication changes?

Hello,

We recently upgraded our JIRA (was using 3.4 and now using 5.1.2). We still have the old install, as we just did a fresh install on a new server.

Everything seems to work except for the subversion plugin. I have checked countless times and tried many different variations to get it to work but for some reason it doesn't want to.

We upgraded our plugin from 0.10.5.4 to 0.10.11

As of now, I've:

Checked the SVN repo link (http) from the browser on both servers using the same credentials and both servers can access it.

I've removed the repo's from both sections in administation, made sure both subversion-jira-plugin.properties files had the same configs, and restarted the JIRA instances. Old server comes with an activated repo, while the other asks to activate it. It fails to activate on attempt.

When trying to add the repo manually on the new server, I receive the following error:

Subversion Revision Indexing Service [plugin.ext.subversion.SubversionManagerImpl] Connection to Subversion repository http://XXXXXXX:8888/svn/XXXXXX failed: org.tmatesoft.svn.core.SVNAuthenticationException: svn: E170001: Authentication required for '<http://XXXXXXX:8888> Subversion repository'
org.tmatesoft.svn.core.SVNAuthenticationException: svn: E170001: Authentication required for '<http://XXXXXXX:8888> Subversion repository'

(Obviously not XXX's)

I've also dug into the database instances and checked the property values / keys for the plugin. Both are identical on JIRA service restart.

Any thoughts on the matter would be very appreciated.

Thanks,

Chris

3 answers

1 accepted

This widget could not be displayed.

For me I had to add the following to the JVM parameters (edited the service in regedit):

-Dsvnkit.http.methods=Basic,Digest,Negotiate,NTLM

To find the service in regedit, just lookup the Service name in services.msc (e.g. JIRA031011191852) and search for it in regedit.

This solved the exact error you are reporting.

Thanks, this worked.

Great! Please select this as the correct answer to your question so other users have a better chance of finding the solution!

This widget could not be displayed.

Here are a few things to check. Verify that your site certificate is up to date. (Ours wasn't.) The authentication issue may be coming from an old site certificate. JIRA may be getting a pop-up that asks if you want to accept the certificate.

Also, if using SSL be sure it's enabled in the JVM input arguments.

-Dsvnkit.http.sslProtocols=SSLv3

Teresa

This widget could not be displayed.

Not very sure about this answer, but you can try out. Can you clear the directory ~/.subversion on the server that is hosting JIRA (for the same user account which is running JIRA)?

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Published Jul 25, 2018 in Marketplace Apps

Jira Cloud and Bitbucket Cloud Integration with Microsoft Teams

One of the newest products in the Microsoft family - Microsoft Teams,  is a chat-based hub for teamwork that integrates all the people, content, and tools your team needs to be more engaged and ...

716 views 0 3
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you