Unable to display a jira table value using the Kepler db plugin

Hi there,

I'm trying to use this plugin to pull in a list of names from the projectrole table within Jira itself using the add in. I already have this database listed in the context.xml file.

e.g

<Resource name="JIRA_PROD" auth="Container" type="javax.sql.DataSource" username="nnnn" password="nnn" driverClassName="net.sourceforge.jtds.jdbc.Driver" url="jdbc:jtds:sqlserver://servername:port/JIRA_PROD;instance=INSTANCE1" />
</Context>

However when I configure it as below, nothing appears in the drop down. Is there something else that I need to do?

I aleady have another table (non-native) in the Jira database referenced and that works fine.

Thanks in advance

4 answers

1 accepted

Hi - thanks for the response. I checked the logs and found that the sql query was incorrect. After a bit of checking I found out that I had to use the full table name (i.e. jira.projectrole) and this worked.

Do you have any errors in the logs?

which log file did you look at to determine this?

You should look into atlassian-jira log file, located under the JIRA_HOME/log folder.

So there's no real problem, but the config. Please mark it as solved

Thanks,

R.

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Published May 30, 2018 in Marketplace Apps

Three tips for boosting your board's efficiency with Story Maps

Trello is one of the most effective tools for driving your sprints. It's customizable for every Agile team and product owners and Scrum masters (SM) love it. However, Agile teams often struggle with:...

839 views 2 9
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you